Jetty
  1. Jetty
  2. JETTY-387

Firefox/Mozilla problem sending data with POST method via HTTPS

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 6.1.4
    • Fix Version/s: None
    • Component/s: Security and SSL
    • Labels:
      None
    • Environment:
      Gentoo Linux, Firefox, JSDK 1.5
    • Number of attachments :
      1

      Description

      Hello
      The problem is that when data is sent from Firefox/Mozilla browsers via HTTPS connection it doesn't processed by Jetty (no access logs are produced).
      This only happens when using org.mortbay.jetty.security.SslSelectChannelConnector. With blocking connector data is received and processed OK.

      1. Bug doesn't occur in other browsers (Opera/IE).
      2. When testing the same page / same keystore file with Tomcat 5.5.20 - it is working OK.

      The jetty.xml and JSP page to replicate the bug are attached.

      1. filez.tgz
        0.7 kB
        Evgeny Shepelyuk

        Activity

        Hide
        Jan Bartel added a comment -

        Evgeny,

        This is working for me with Firefox (2.0.0.4). I did notice however that if using jdk1.5_09 the https request would seem to hang, and therefore never be logged in the access log. Upgrading to jdk.1.5_11 fixed it, so it seems there could be a jvm bug involved here.

        Show
        Jan Bartel added a comment - Evgeny, This is working for me with Firefox (2.0.0.4). I did notice however that if using jdk1.5_09 the https request would seem to hang, and therefore never be logged in the access log. Upgrading to jdk.1.5_11 fixed it, so it seems there could be a jvm bug involved here.
        Hide
        Evgeny Shepelyuk added a comment -

        Works ok after update of jsdk1.5 to latest build.
        Sorry for bothering.

        Show
        Evgeny Shepelyuk added a comment - Works ok after update of jsdk1.5 to latest build. Sorry for bothering.
        Hide
        Jan Bartel added a comment -

        Evgeny,

        Thanks for bringing this to our attention. I've added a "Troubleshooting" entry about this problem on the wiki.

        cheers
        Jan

        Show
        Jan Bartel added a comment - Evgeny, Thanks for bringing this to our attention. I've added a "Troubleshooting" entry about this problem on the wiki. cheers Jan
        Hide
        Bernd Schuller added a comment -

        I experience a similar issue (using PUT not POST) with Java build 1.6.0_10-b33 and Jetty 6.1.x (where x in 8...15)
        Any ideas on what might cause this?

        Thanks,
        Bernd.

        Show
        Bernd Schuller added a comment - I experience a similar issue (using PUT not POST) with Java build 1.6.0_10-b33 and Jetty 6.1.x (where x in 8...15) Any ideas on what might cause this? Thanks, Bernd.
        Hide
        Athena Yao added a comment -

        As you're using Java 1.6, I wonder if it could be related to http://jira.codehaus.org/browse/JETTY-567?

        Show
        Athena Yao added a comment - As you're using Java 1.6, I wonder if it could be related to http://jira.codehaus.org/browse/JETTY-567?

          People

          • Assignee:
            Jan Bartel
            Reporter:
            Evgeny Shepelyuk
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: