Jetty
  1. Jetty
  2. JETTY-200

Error while servlet out size > 64k

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 6.0.1
    • Fix Version/s: 6.1.0rc1
    • Component/s: None
    • Labels:
      None
    • Environment:
      Windows XP SP2, Java 6, Opera 9.10.8660, Jetty works as a service with Service Wrapper 3.2.3
    • Number of attachments :
      0

      Description

      In JSP after POST request, when page size generated as result in JSP is more than 64k, nothing returned, (IE 6 displays error message "Unable to connect to specified server", Opera displays previous page). Log file looks like this:
      -------
      null - - [14/12/2006:09:07:22 +0000] "POST /informer/sms.jsp HTTP/1.1" 200 65536

      Please note:
      1. Address is specified as null
      2. Status is 200, i.e. Jetty "thinks" it's all ok
      3. Result size is 65536, exact 64k!

      I suppose, some kind of buffer inside of Jetty has limit of 64k, and this error is because of this.
      Is there any way to investigate it more deply for me? If I set log level to lowest, will error be displayed?

        Activity

        Greg Wilkins added a comment -

        I am 95% sure this is fixed in 6.0.1 and 99% sure it is fixed in 6.1.0rc1

        there was a issue with a full buffer not triggering a flush in 6.0.1

        Greg Wilkins made changes -
        Field Original Value New Value
        Assignee Greg Wilkins [ gregw ]
        Greg Wilkins added a comment -

        Marking as fixed, because I can't reproduce so I expect my suspicions to be true.

        Greg Wilkins made changes -
        Fix Version/s 6.1.0rc1 [ 13071 ]
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Resolved [ 5 ]

          People

          • Assignee:
            Greg Wilkins
            Reporter:
            Lonewolf
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: