Jetty
  1. Jetty
  2. JETTY-156

Problems running the jetty maven2 plugin on a project

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: J2EE/Extra, Maven, Servlet
    • Labels:
      None
    • Environment:
      Windows and linux.
      1G ram
    • Number of attachments :
      2

      Description

      Problems running the jetty maven2 plugin on a project .
      The project has tomahawk, myfaces, hibernate, and adf faces jar libs...

      the attachement contains the pom.xml

      I have a JDeveloper project running all ok, and now I'm trying to move it to Maven 2 and Jetty plugin to rapid development.

      Here is the strack trace:
      2006-10-30 10:33:46.776::WARN: /ntier/accesscontrol/login.jspx:
      java.lang.ClassCastException: javax.faces.component.UIViewRoot
      at oracle.adf.view.faces.webapp.UIXComponentTag.setProperties(UIXCompone
      ntTag.java:115)
      at javax.faces.webapp.UIComponentTag.findComponent(UIComponentTag.java:5
      36)
      at javax.faces.webapp.UIComponentTag.doStartTag (UIComponentTag.java:312)

      at oracle.adf.view.faces.webapp.UIXComponentTag.doStartTag(UIXComponentT
      ag.java:85)
      at org.apache.jsp.accesscontrol.login_jspx._jspx_meth_afh_html_0(org.apa
      che.jsp.accesscontrol.login_jspx:114 )
      at org.apache.jsp.accesscontrol.login_jspx._jspService(org.apache.jsp.ac
      cesscontrol.login_jspx:91)
      at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java :111)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
      at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper
      .java:358)
      at org.apache.jasper.servlet.JspServlet.serviceJspFile (JspServlet.java:4
      40)
      at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:335)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
      at org.mortbay.jetty.servlet.ServletHolder.handle (ServletHolder.java:445
      )
      at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:3
      54)
      at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:2
      30)
      at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:6
      27)
      at org.mortbay.jetty.servlet.Dispatcher.forward(Dispatcher.java:266)
      at org.mortbay.jetty.servlet.Dispatcher.forward(Dispatcher.java :126)
      at org.apache.myfaces.context.servlet.ServletExternalContextImpl.dispatc
      h(ServletExternalContextImpl.java:416)
      at org.apache.myfaces.application.jsp.JspViewHandlerImpl.renderView(JspV
      iewHandlerImpl.java :234)
      at oracle.adfinternal.view.faces.application.ViewHandlerImpl.renderView(
      ViewHandlerImpl.java:157)
      at org.apache.myfaces.lifecycle.LifecycleImpl.render(LifecycleImpl.java:
      384)
      at javax.faces.webapp.FacesServlet.service(FacesServlet.java:138)
      at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:445
      )
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter (Servlet
      Handler.java:1049)
      at oracle.adfinternal.view.faces.webapp.AdfFacesFilterImpl._invokeDoFilt
      er(AdfFacesFilterImpl.java:367)
      at oracle.adfinternal.view.faces.webapp.AdfFacesFilterImpl._doFilterImpl
      (AdfFacesFilterImpl.java:336)
      at oracle.adfinternal.view.faces.webapp.AdfFacesFilterImpl.doFilter(AdfF
      acesFilterImpl.java:196)
      at oracle.adf.view.faces.webapp.AdfFacesFilter.doFilter(AdfFacesFilter.j
      ava:87)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(Servlet
      Handler.java:1040)
      at org.apache.myfaces.webapp.filter.ExtensionsFilter.doFilter(Extensions
      Filter.java:144)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(Servlet
      Handler.java:1040)
      at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:3
      52)
      at org.mortbay.jetty.servlet.SessionHandler.handle (SessionHandler.java:2
      30)
      at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:6
      27)
      at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHand
      lerCollection.java :149)
      at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.
      java:123)
      at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:1
      41)
      at org.mortbay.jetty.Server.handle (Server.java:286)
      at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:44
      4)
      at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpCo
      nnection.java:701)
      at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:500)
      at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:203)
      at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:340)
      at org.mortbay.jetty.nio.HttpChannelEndPoint.run(HttpChannelEndPoint.jav
      a:270)
      at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool
      .java:475)
      2006-10-30 10:33:46.776::WARN: /ntier/accesscontrol/login.jspx
      java.lang.ClassCastException: javax.faces.component.UIViewRoot
      at oracle.adf.view.faces.webapp.UIXComponentTag.setProperties(UIXCompone
      ntTag.java:115)
      at javax.faces.webapp.UIComponentTag.findComponent (UIComponentTag.java:5
      36)
      at javax.faces.webapp.UIComponentTag.doStartTag(UIComponentTag.java:312)

      at oracle.adf.view.faces.webapp.UIXComponentTag.doStartTag(UIXComponentT
      ag.java:85)
      at org.apache.jsp.accesscontrol.login_jspx._jspx_meth_afh_html_0(org.apa
      che.jsp.accesscontrol.login_jspx:114)
      at org.apache.jsp.accesscontrol.login_jspx._jspService(org.apache.jsp.ac
      cesscontrol.login_jspx:91)
      at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:111)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
      at org.apache.jasper.servlet.JspServletWrapper.service (JspServletWrapper
      .java:358)
      at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:4
      40)
      at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:335)
      at javax.servlet.http.HttpServlet.service (HttpServlet.java:802)
      at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:445
      )
      at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:3
      54)
      at org.mortbay.jetty.servlet.SessionHandler.handle (SessionHandler.java:2
      30)
      at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:6
      27)
      at org.mortbay.jetty.servlet.Dispatcher.forward(Dispatcher.java:266)
      at org.mortbay.jetty.servlet.Dispatcher.forward (Dispatcher.java:126)
      at org.apache.myfaces.context.servlet.ServletExternalContextImpl.dispatc
      h(ServletExternalContextImpl.java:416)
      at org.apache.myfaces.application.jsp.JspViewHandlerImpl.renderView (JspV
      iewHandlerImpl.java:234)
      at oracle.adfinternal.view.faces.application.ViewHandlerImpl.renderView(
      ViewHandlerImpl.java:157)
      at org.apache.myfaces.lifecycle.LifecycleImpl.render(LifecycleImpl.java :
      384)
      at javax.faces.webapp.FacesServlet.service(FacesServlet.java:138)
      at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:445
      )
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter (Servlet
      Handler.java:1049)
      at oracle.adfinternal.view.faces.webapp.AdfFacesFilterImpl._invokeDoFilt
      er(AdfFacesFilterImpl.java:367)
      at oracle.adfinternal.view.faces.webapp.AdfFacesFilterImpl._doFilterImpl
      (AdfFacesFilterImpl.java:336)
      at oracle.adfinternal.view.faces.webapp.AdfFacesFilterImpl.doFilter(AdfF
      acesFilterImpl.java:196)
      at oracle.adf.view.faces.webapp.AdfFacesFilter.doFilter(AdfFacesFilter.j
      ava:87)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(Servlet
      Handler.java:1040)
      at org.apache.myfaces.webapp.filter.ExtensionsFilter.doFilter(Extensions
      Filter.java:144)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(Servlet
      Handler.java:1040)
      at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:3
      52)
      at org.mortbay.jetty.servlet.SessionHandler.handle (SessionHandler.java:2
      30)
      at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:6
      27)
      at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHand
      lerCollection.java :149)
      at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.
      java:123)
      at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:1
      41)
      at org.mortbay.jetty.Server.handle (Server.java:286)
      at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:44
      4)
      at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpCo
      nnection.java:701)
      at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:500)
      at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:203)
      at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:340)
      at org.mortbay.jetty.nio.HttpChannelEndPoint.run(HttpChannelEndPoint.jav
      a:270)
      at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool
      .java:475)
      30/10/2006 10:33:46 oracle.adfinternal.view.faces.renderkit.RenderKitBase getRen
      derer
      WARNING: Renderer 'oracle.adf.Html' not found for component family 'javax.faces.
      ViewRoot'
      2006-10-30 10:33:46.932:/ntier:INFO: No Renderer found for component

      {Component -Path : [Class: javax.faces.component.UIViewRoot ,ViewId: /accesscontrol/login.js px]}

      (component-family=javax.faces.ViewRoot, renderer-type=oracle.adf.Html)

      1. pom.xml
        4 kB
        dudu
      1. mvn.JPG
        92 kB

        Activity

        dudu added a comment -

        The version of Maven Jetty Plugin is the jetty-6.1.0pre0

        Jan Bartel added a comment -

        Looks to me like maybe you have 2 versions of faces on your classpath from 2 different jars. This problem may be revealed by the plugin simply because the order of the jars are different (according to your pom.xml) than in your IDE.

        dudu added a comment -

        Jan Bartel,
        keep the issue Open. I'll try again based on your comment.
        thanks

        dudu added a comment -

        I think there is no 2 jsf implementations...
        Here is my pom.xml.

        <dependencies>
        <dependency>
        <groupId>junit</groupId>
        <artifactId>junit</artifactId>
        <version>4.0</version>
        <scope>test</scope>
        </dependency>
        <dependency>
        <groupId>hibernate</groupId>
        <artifactId>hibernate</artifactId>
        <version>3.0.5</version>
        <scope>compile</scope>
        </dependency>
        <dependency>
        <groupId>log4j</groupId>
        <artifactId>log4j</artifactId>
        <version>1.2.12</version>
        <scope>compile</scope>
        </dependency>
        <dependency>
        <groupId>ojdbc</groupId>
        <artifactId>ojdbc</artifactId>
        <version>14</version>
        <scope>compile</scope>
        </dependency>
        <dependency>
        <groupId>javax.mail</groupId>
        <artifactId>mail</artifactId>
        <version>1.4</version>
        <scope>compile</scope>
        </dependency>
        <dependency>
        <groupId>commons-configuration</groupId>
        <artifactId>commons-configuration</artifactId>
        <version>1.3</version>
        <scope>compile</scope>
        </dependency>
        <dependency>
        <groupId>commons-fileupload</groupId>
        <artifactId>commons-fileupload</artifactId>
        <version>1.1.1</version>
        <scope>compile</scope>
        </dependency>
        <dependency>
        <groupId>oracle.adf</groupId>
        <artifactId>adf-faces-impl</artifactId>
        <version>10.1.3.0.4</version>
        <scope>compile</scope>
        </dependency>
        <dependency>
        <groupId>oracle.adf</groupId>
        <artifactId>adf-faces-api</artifactId>
        <version>10.1.3.0.4</version>
        <scope>compile</scope>
        </dependency>
        <dependency>
        <groupId>javax.faces</groupId>
        <artifactId>jsf-api</artifactId>
        <version>1.1_02</version>
        <scope>compile</scope>
        </dependency>
        <dependency>
        <groupId>javax.faces</groupId>
        <artifactId>jsf-impl</artifactId>
        <version>1.1_02</version>
        <scope>compile</scope>
        </dependency>
        <dependency>
        <groupId>myfaces</groupId>
        <artifactId>tomahawk</artifactId>
        <version>1.1.3</version>
        <scope>compile</scope>
        </dependency>
        <dependency>
        <groupId>javax.servlet</groupId>
        <artifactId>servlet-api</artifactId>
        <version>2.4</version>
        <scope>compile</scope>
        </dependency>
        <dependency>
        <groupId>javax.servlet</groupId>
        <artifactId>jsp-api</artifactId>
        <version>2.0</version>
        <scope>compile</scope>
        </dependency>
        <dependency>
        <groupId>javax.servlet</groupId>
        <artifactId>jstl</artifactId>
        <version>1.1.2</version>
        <scope>compile</scope>
        </dependency>
        <dependency>
        <groupId>org.apache.shale</groupId>
        <artifactId>shale-test</artifactId>
        <version>1.0.3</version>
        <scope>test</scope>
        </dependency>
        </dependencies>
        <build>
        <finalName>sagweb</finalName>
        <plugins>
        <plugin>
        <artifactId>maven-compiler-plugin</artifactId>
        <configuration>
        <source>1.5</source>
        <target>1.5</target>
        </configuration>
        </plugin>
        <plugin>
        <groupId>org.mortbay.jetty</groupId>
        <artifactId>maven-jetty-plugin</artifactId>
        <version>6.0.1</version>
        <configuration>
        <connectors>
        <connector
        implementation="org.mortbay.jetty.nio.SelectChannelConnector">
        <port>8081</port>
        </connector>
        </connectors>
        </configuration>
        </plugin>
        </plugins>
        </build>
        </project>

        Jan Bartel added a comment -

        Dudu,

        I don't know about the oracle adf-faces package, but you've got 2 jsf impls here:
        <groupId>javax.faces</groupId>
        <artifactId>jsf-api</artifactId>
        <version>1.1_02</version>
        <scope>compile</scope>
        </dependency>
        <dependency>
        <groupId>javax.faces</groupId>
        <artifactId>jsf-impl</artifactId>
        <version>1.1_02</version>
        <scope>compile</scope>
        </dependency>
        <dependency>
        <groupId>myfaces</groupId>
        <artifactId>tomahawk</artifactId>
        <version>1.1.3</version>
        <scope>compile</scope>
        </dependency>

        They've both got scope "compile" which means they'll both be present in the generated war file and also on the plugin's execution path. You should only need one of these.

        regards
        Jan

        dudu added a comment -

        Oracle ADF( now myfaces trinidad) is a component package as myfaces Tomahawk, and it's not a jsf implementation...
        To use oracle adf, a jsf implemetation is needed, like myfaces or Sun RI.

        Jan Bartel added a comment -

        Are you sure you're not getting 2 different jsf api jars on the classpath via transitive dependencies? You can check with mvn -X jetty:run.

        dudu added a comment -

        Here are the dependencies...

        Obs: The myfaces jsf implementation is in "test" scope.
        Maybe other jar are conflicting and the container is throwing the wrong error.

        Jan Bartel added a comment -

        Doing the mvn -X jetty:run gives you the exact jars in order on the classpath at runtime, so I think you need to look at that rather than the maven dependencies page.

        Also, from the pom it seems that only shale is in scope "test" and everything else is "compile" which means they will be on the classpath at runtime.

        You need to remove the jsp-api-2.0 jar from the dependencies, or change it to jsp-2.1 and make it scope "provided".Otherwise you will wind up with 2 different jsp api jars at runtime (one from your webapp's pom and one from jetty) will conflict .

        And finally, JSF as of javaee5 is regarded as a server resource, and thus apparently is not to be included in individual webapps. Jetty being a servlet2.5/javaee container, some of the setup for faces requires that the faces jars are on the server's classpath, not the webapp's. Therefore, you will probably need to move the jsf api and impl jars to be <dependency>s for the <plugin>, which is equivalent to putting it on the server's classpath rather than the webapp's classpath.

        dudu added a comment -

        Doesn't works.....

        If my application wouldn't commercial it should be more easy to solve this issue.
        I don't know what to do more.

        I have another (facelets + adffaces + hibernate + etc) project, and it works perfectly on jetty. This project who is not working has only tomahawk , and doesn't have facelets, this is the uniques diferences.... and I've tried to change this differences but whitouth sucess...

        I'll stop to try to use jetty plugin on this project momentanly..

        Jan Bartel added a comment -

        Dudu, did you get any further with this? Perhaps you can try with 6.1.0rc0, which upgrades the version of jasper which may address some of your problems.

        dudu added a comment -

        In the past, I've tried with a 6.x.x beta version of the plugin...
        I think if this problem is occuring only with me, it can be ignored and this issue closed, at least at this moment

        Jan Bartel added a comment -

        Reopen if necessary.


          People

          • Assignee:
            Jan Bartel
            Reporter:
            dudu
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: