Jetty
  1. Jetty
  2. JETTY-1493

Maven Dependency Behaviour Orbit Package Type

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Not A Bug
    • Affects Version/s: 7.6.1
    • Fix Version/s: None
    • Component/s: Packaging
    • Labels:
      None
    • Environment:
      Apache Ivy
    • Number of attachments :
      0

      Description

      http://mvnrepository.com/artifact/org.eclipse.jetty/jetty-server/7.6.1.v20120215

      depends on

      http://mvnrepository.com/artifact/org.eclipse.jetty.orbit/javax.servlet/2.5.0.v201103041518

      The latter has a package type of 'orbit' which causes maven to think the target extension should be '.orbit'. Since it's actually a JAR, both the button on the latter page (Download (ORBIT)) and my local Ivy resolution chain are broken.

        Issue Links

          Activity

          Jesse McConnell made changes -
          Field Original Value New Value
          Status Open [ 1 ] Resolved [ 5 ]
          Assignee Jesse McConnell [ jesse ]
          Resolution Not A Bug [ 6 ]
          Joakim Erdfelt made changes -
          Link This issue is duplicated by JETTY-1543 [ JETTY-1543 ]

            People

            • Assignee:
              Jesse McConnell
              Reporter:
              Andre Ben Hamou
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: