Jetty
  1. Jetty
  2. JETTY-1473

Jetty container hangs after some time

    Details

    • Type: Test Test
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 8.0.4
    • Fix Version/s: None
    • Component/s: Eclipse
    • Labels:
      None
    • Environment:
      Servers: HP DL-380 G7 series with 16 GB RAM, RHEL 5.4, 64-bit OS.

      JAVA_OPTS: JAVA_OPTS="$JAVA_OPTS -Djava.net.preferIPv4Stack=true -Xms8192m -Xmx8192m -server -XX:+UseNUMA

      Network speed - 1 GIG switch.
    • Number of attachments :
      1

      Description

      Hi.

      I am using Jetty 8.0.4 stable release binary.

      During my testing, I am pumping a load of 100 HTTP requests per second.

      After sometime, Jetty stops responding to the incoming requests and hangs. The first few hundred requests are processed in a normal fashion, and later the Jetty container hangs.

      The details of my enviornment are as follows -

      Servers: HP DL-380 G7 series with 16 GB RAM, RHEL 5.4, 64-bit OS.

      JAVA_OPTS: JAVA_OPTS="$JAVA_OPTS -Djava.net.preferIPv4Stack=true -Xms8192m -Xmx8192m -server -XX:+UseNUMA

      Network speed - 1 GIG switch.

      Upon executing thte netstat commond on RHEL, I observed that there are many TCP connections in TIME_WAIT state.

      In my Jetty handler code, I am returning a response and not hogging the threads.

      I could not obtain a thread dump, as I was unable to connect to the Jetty process using JCONSOLE (all sockets were occupied as mentioned earlier).

      However, I am attaching the netstat command(netstat -p <pid>) output with this post.

      Please, let me know the steps to debug this issue, and I will help in getting to the root cause of this issue.

      1. netstat.rtf
        53 kB
        vikash agrawal

        Activity

        Jan Bartel added a comment -

        Have you tuned the os and jetty for load testing? Please see:

        http://wiki.eclipse.org/Jetty/Howto/High_Load

        regards
        Jan

        Jan Bartel added a comment -

        Also please use 8.1.0.RC4 as the most recent release candidate, and the basis for final release.

        Jan

        Jan Bartel added a comment -

        Vikash,

        Jetty is now at release 8.1.1, and there are many many changes to the nio layer. I suggest reading the wiki page on high load and then trying 8.1.1. If you still have a problem, then please provide thread dumps, netstat output and tcpdump traces.

        thanks
        Jan

        Jan Bartel added a comment -

        There's been no feedback on this issue for a while and not enough info to go on to do anything with. If you can follow the advice provided, and the problem persists, please reopen and attach tcpdumps, logs etc.

        thanks
        Jan


          People

          • Assignee:
            Jan Bartel
            Reporter:
            vikash agrawal
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: