Jetty
  1. Jetty
  2. JETTY-1449

Unable to execute "run-forked" goal with overlays

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 8.0.3
    • Fix Version/s: 7.6.0
    • Component/s: Maven
    • Labels:
      None
    • Environment:
      Windows XP 32 bit
    • Number of attachments :
      0

      Description

      If you use the jetty-maven-plugin with the "run-forked" goal and have an WAR overlay in your pom you get:

      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 5.500s
      [INFO] Finished at: Tue Oct 25 08:35:54 CEST 2011
      [INFO] Final Memory: 9M/24M
      [INFO] ------------------------------------------------------------------------
      [ERROR] Failed to execute goal org.mortbay.jetty:jetty-maven-plugin:8.0.3.v20111011:run-forked (start-jetty) on project myapp-integration-tests: Failed to create Jetty process: Prepare webapp configuration: NullPointerException -> [Help 1]
      org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.mortbay.jetty:jetty-maven-plugin:8.0.3.v20111011:run-forked (start-jetty) on project myapp-integration-tests: Failed to create Jetty process
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:217)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
      	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
      	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
      	at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
      	at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
      	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:319)
      	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
      	at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
      	at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
      	at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:597)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
      Caused by: org.apache.maven.plugin.MojoExecutionException: Failed to create Jetty process
      	at org.mortbay.jetty.plugin.JettyRunForkedMojo.startJettyRunner(JettyRunForkedMojo.java:578)
      	at org.mortbay.jetty.plugin.JettyRunForkedMojo.execute(JettyRunForkedMojo.java:271)
      	at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:101)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:209)
      	... 19 more
      Caused by: org.apache.maven.plugin.MojoExecutionException: Prepare webapp configuration
      	at org.mortbay.jetty.plugin.JettyRunForkedMojo.prepareConfiguration(JettyRunForkedMojo.java:387)
      	at org.mortbay.jetty.plugin.JettyRunForkedMojo.startJettyRunner(JettyRunForkedMojo.java:506)
      	... 22 more
      Caused by: java.lang.NullPointerException
      	at org.mortbay.jetty.plugin.JettyRunForkedMojo.prepareConfiguration(JettyRunForkedMojo.java:376)
      	... 23 more
      

        Activity

        Jan Bartel added a comment -

        Fixed for 7.5.5.

        Sascha Theves added a comment -

        What`s about a fix for 8.0.x?

        Jan Bartel added a comment -

        Sascha,

        Its also fixed for jetty-8 by way of a merge from jetty-7. You can build it from codehaus trunk if you like.

        Jan


          People

          • Assignee:
            Jan Bartel
            Reporter:
            Sascha Theves
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: