Jetty
  1. Jetty
  2. JETTY-1395

build from source fails because of wrong class file version of servlet-api-3.0.20100224

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 7.4.4
    • Fix Version/s: None
    • Component/s: Continuations
    • Labels:
      None
    • Environment:
      jdk 1.5
      maven 3.0.3
    • Number of attachments :
      0

      Description

      even when I remove the servlet-api package from local maven repository (forcing a new download) I got following error message:

      [INFO] ------------------------------------------------------------------------
      [INFO] Building Jetty :: Continuation 7.4.4-SNAPSHOT
      [INFO] ------------------------------------------------------------------------
      Downloading: http://oss.sonatype.org/content/groups/jetty/org/mortbay/jetty/servlet-api/3.0.20100224/servlet-api-3.0.20100224.pom
      Downloaded: http://oss.sonatype.org/content/groups/jetty/org/mortbay/jetty/servlet-api/3.0.20100224/servlet-api-3.0.20100224.pom
      Downloading: http://oss.sonatype.org/content/groups/jetty/org/mortbay/jetty/servlet-api/3.0.20100224/servlet-api-3.0.20100224.jar
      Downloaded: http://oss.sonatype.org/content/groups/jetty/org/mortbay/jetty/servlet-api/3.0.20100224/servlet-api-3.0.20100224.jar
      [INFO]
      [INFO] — build-helper-maven-plugin:1.5:parse-version (set-osgi-version) @ jetty-continuation —
      [INFO]
      [INFO] — maven-enforcer-plugin:1.0:enforce (enforce-java) @ jetty-continuation —
      [INFO]
      [INFO] — maven-remote-resources-plugin:1.2:process (default) @ jetty-continuation —
      [INFO] Setting property: classpath.resource.loader.class => 'org.codehaus.plexus.velocity.ContextClassLoaderResourceLoader'.
      [INFO] Setting property: velocimacro.messages.on => 'false'.
      [INFO] Setting property: resource.loader => 'classpath'.
      [INFO] Setting property: resource.manager.logwhenfound => 'false'.
      [INFO]
      [INFO] — maven-resources-plugin:2.5:resources (default-resources) @ jetty-continuation —
      [debug] execute contextualize
      [INFO] Using 'UTF-8' encoding to copy filtered resources.
      [INFO] skip non existing resourceDirectory \devel\jetty-7-eclipse\jetty-continuation\src\main\resources
      [INFO] Copying 1 resource
      [INFO]
      [INFO] — maven-compiler-plugin:2.3.2:compile (default-compile) @ jetty-continuation —
      [INFO] Compiling 8 source files to \devel\jetty-7-eclipse\jetty-continuation\target\classes
      [INFO] -------------------------------------------------------------
      [ERROR] COMPILATION ERROR :
      [INFO] -------------------------------------------------------------
      [ERROR] \devel\jetty-7-eclipse\jetty-continuation\src\main\java\org\eclipse\jetty\continuation\ContinuationListener.java:[6,-1] cannot access javax.servlet.ServletRequestListener
      bad class file: \tools\.m2\repository\org\mortbay\jetty\servlet-api\3.0.20100224\servlet-api-3.0.20100224.jar(javax/servlet/ServletRequestListener.class)
      class file has wrong version 50.0, should be 49.0
      [INFO] 1 error

        Activity

        No work has yet been logged on this issue.

          People

          • Assignee:
            Jan Bartel
            Reporter:
            Thanassis Papathanasiou
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: