Jetty
  1. Jetty
  2. JETTY-1392

ClassNotFoundException thrown when @WebMethod signature contains a generic collection parameter plus a byte array

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Not A Bug
    • Affects Version/s: 7.2.0
    • Fix Version/s: None
    • Component/s: Maven
    • Labels:
      None
    • Environment:
    • Testcase included:
      yes
    • Number of attachments :
      0

      Description

      Running "mvn jetty:run", if my web service class contains a method which includes both a byte [] and a "raw" collection, e.g.

      @SuppressWarnings("rawtypes")
      public ServiceOutput readStuff(final byte [] token, final List keyList)

      { ... }

      ... there is no problem. If however I use a generic collection...

      public ServiceOutput readStuff(final byte [] token, final List<Integer> keyList) { ... }

      ... then jetty:run fails with the stack below. The parameter order doesn't seem to matter.

      Jul 7, 2011 6:37:53 PM com.sun.xml.ws.transport.http.servlet.WSServletContextListener contextInitialized
      SEVERE: WSSERVLET11: failed to parse runtime descriptor: java.lang.TypeNotPresentException: Type byte not present
      java.lang.TypeNotPresentException: Type byte not present
      at sun.reflect.generics.factory.CoreReflectionFactory.makeNamedType(CoreReflectionFactory.java:98)
      at sun.reflect.generics.visitor.Reifier.visitClassTypeSignature(Reifier.java:107)
      at sun.reflect.generics.tree.ClassTypeSignature.accept(ClassTypeSignature.java:31)
      at sun.reflect.generics.visitor.Reifier.visitArrayTypeSignature(Reifier.java:141)
      at sun.reflect.generics.tree.ArrayTypeSignature.accept(ArrayTypeSignature.java:24)
      at sun.reflect.generics.repository.FieldRepository.getGenericType(FieldRepository.java:67)
      at java.lang.reflect.Field.getGenericType(Field.java:223)
      at com.sun.xml.bind.v2.model.nav.ReflectionNavigator.getFieldType(ReflectionNavigator.java:273)
      at com.sun.xml.bind.v2.model.nav.ReflectionNavigator.getFieldType(ReflectionNavigator.java:58)
      at com.sun.xml.bind.v2.model.impl.FieldPropertySeed.getRawType(FieldPropertySeed.java:74)
      at com.sun.xml.bind.v2.model.impl.RuntimeClassInfoImpl$RuntimePropertySeed.getRawType(RuntimeClassInfoImpl.java:315)
      at com.sun.xml.bind.v2.model.impl.RuntimeClassInfoImpl$RuntimePropertySeed.getRawType(RuntimeClassInfoImpl.java:289)
      at com.sun.xml.bind.v2.model.impl.PropertyInfoImpl.<init>(PropertyInfoImpl.java:119)
      at com.sun.xml.bind.v2.model.impl.ERPropertyInfoImpl.<init>(ERPropertyInfoImpl.java:53)
      at com.sun.xml.bind.v2.model.impl.ElementPropertyInfoImpl.<init>(ElementPropertyInfoImpl.java:96)
      at com.sun.xml.bind.v2.model.impl.RuntimeElementPropertyInfoImpl.<init>(RuntimeElementPropertyInfoImpl.java:59)
      at com.sun.xml.bind.v2.model.impl.RuntimeClassInfoImpl.createElementProperty(RuntimeClassInfoImpl.java:165)
      at com.sun.xml.bind.v2.model.impl.ClassInfoImpl.addProperty(ClassInfoImpl.java:868)
      at com.sun.xml.bind.v2.model.impl.ClassInfoImpl.findFieldProperties(ClassInfoImpl.java:398)
      at com.sun.xml.bind.v2.model.impl.ClassInfoImpl.getProperties(ClassInfoImpl.java:301)
      at com.sun.xml.bind.v2.model.impl.RuntimeClassInfoImpl.getProperties(RuntimeClassInfoImpl.java:176)
      at com.sun.xml.bind.v2.model.impl.ModelBuilder.getClassInfo(ModelBuilder.java:243)
      at com.sun.xml.bind.v2.model.impl.RuntimeModelBuilder.getClassInfo(RuntimeModelBuilder.java:100)
      at com.sun.xml.bind.v2.model.impl.RuntimeModelBuilder.getClassInfo(RuntimeModelBuilder.java:81)
      at com.sun.xml.bind.v2.model.impl.ModelBuilder.getClassInfo(ModelBuilder.java:209)
      at com.sun.xml.bind.v2.model.impl.RuntimeModelBuilder.getClassInfo(RuntimeModelBuilder.java:95)
      at com.sun.xml.bind.v2.model.impl.RuntimeModelBuilder.getClassInfo(RuntimeModelBuilder.java:81)
      at com.sun.xml.bind.v2.model.impl.ModelBuilder.getTypeInfo(ModelBuilder.java:315)
      at com.sun.xml.bind.v2.model.impl.ModelBuilder.getTypeInfo(ModelBuilder.java:330)
      at com.sun.xml.bind.v2.runtime.JAXBContextImpl.getTypeInfoSet(JAXBContextImpl.java:441)
      at com.sun.xml.bind.v2.runtime.JAXBContextImpl.<init>(JAXBContextImpl.java:288)
      at com.sun.xml.bind.v2.runtime.JAXBContextImpl$JAXBContextBuilder.build(JAXBContextImpl.java:1111)
      at com.sun.xml.bind.v2.ContextFactory.createContext(ContextFactory.java:154)
      at com.sun.xml.bind.api.JAXBRIContext.newInstance(JAXBRIContext.java:106)
      at com.sun.xml.ws.developer.JAXBContextFactory$1.createJAXBContext(JAXBContextFactory.java:109)
      at com.sun.xml.ws.model.AbstractSEIModelImpl$1.run(AbstractSEIModelImpl.java:159)
      at com.sun.xml.ws.model.AbstractSEIModelImpl$1.run(AbstractSEIModelImpl.java:152)
      at java.security.AccessController.doPrivileged(Native Method)
      at com.sun.xml.ws.model.AbstractSEIModelImpl.createJAXBContext(AbstractSEIModelImpl.java:151)
      at com.sun.xml.ws.model.AbstractSEIModelImpl.postProcess(AbstractSEIModelImpl.java:94)
      at com.sun.xml.ws.model.RuntimeModeler.buildRuntimeModel(RuntimeModeler.java:255)
      at com.sun.xml.ws.server.EndpointFactory.createSEIModel(EndpointFactory.java:323)
      at com.sun.xml.ws.server.EndpointFactory.createEndpoint(EndpointFactory.java:189)
      at com.sun.xml.ws.api.server.WSEndpoint.create(WSEndpoint.java:467)
      at com.sun.xml.ws.transport.http.DeploymentDescriptorParser.parseAdapters(DeploymentDescriptorParser.java:253)
      at com.sun.xml.ws.transport.http.DeploymentDescriptorParser.parse(DeploymentDescriptorParser.java:147)
      at com.sun.xml.ws.transport.http.servlet.WSServletContextListener.contextInitialized(WSServletContextListener.java:108)
      at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:634)
      at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:228)
      at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1098)
      at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:577)
      at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:483)
      at org.mortbay.jetty.plugin.JettyWebAppContext.doStart(JettyWebAppContext.java:160)
      at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
      at org.eclipse.jetty.server.handler.HandlerCollection$1.run(HandlerCollection.java:200)
      at org.eclipse.jetty.util.thread.QueuedThreadPool$2.run(QueuedThreadPool.java:450)
      at java.lang.Thread.run(Thread.java:680)
      Caused by: java.lang.ClassNotFoundException: byte
      at org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy.loadClass(SelfFirstStrategy.java:50)
      at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:244)
      at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:230)
      at org.eclipse.jetty.webapp.WebAppClassLoader.loadClass(WebAppClassLoader.java:428)
      at org.eclipse.jetty.webapp.WebAppClassLoader.loadClass(WebAppClassLoader.java:381)
      at java.lang.Class.forName0(Native Method)
      at java.lang.Class.forName(Class.java:247)
      at sun.reflect.generics.factory.CoreReflectionFactory.makeNamedType(CoreReflectionFactory.java:95)
      ... 56 more
      2011-07-07 18:37:53.622:WARN::Failed startup of context JettyWebAppContext@219b6225@219b6225/,file: <...removed...>
      com.sun.xml.ws.transport.http.servlet.WSServletException: WSSERVLET11: failed to parse runtime descriptor: java.lang.TypeNotPresentException: Type byte not present
      at com.sun.xml.ws.transport.http.servlet.WSServletContextListener.contextInitialized(WSServletContextListener.java:118)
      at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:634)
      at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:228)
      at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1098)
      at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:577)
      at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:483)
      at org.mortbay.jetty.plugin.JettyWebAppContext.doStart(JettyWebAppContext.java:160)
      at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
      at org.eclipse.jetty.server.handler.HandlerCollection$1.run(HandlerCollection.java:200)
      at org.eclipse.jetty.util.thread.QueuedThreadPool$2.run(QueuedThreadPool.java:450)
      at java.lang.Thread.run(Thread.java:680)
      Caused by:
      java.lang.TypeNotPresentException: Type byte not present
      at sun.reflect.generics.factory.CoreReflectionFactory.makeNamedType(CoreReflectionFactory.java:98)
      at sun.reflect.generics.visitor.Reifier.visitClassTypeSignature(Reifier.java:107)
      at sun.reflect.generics.tree.ClassTypeSignature.accept(ClassTypeSignature.java:31)
      at sun.reflect.generics.visitor.Reifier.visitArrayTypeSignature(Reifier.java:141)
      at sun.reflect.generics.tree.ArrayTypeSignature.accept(ArrayTypeSignature.java:24)
      at sun.reflect.generics.repository.FieldRepository.getGenericType(FieldRepository.java:67)
      at java.lang.reflect.Field.getGenericType(Field.java:223)
      at com.sun.xml.bind.v2.model.nav.ReflectionNavigator.getFieldType(ReflectionNavigator.java:273)
      at com.sun.xml.bind.v2.model.nav.ReflectionNavigator.getFieldType(ReflectionNavigator.java:58)
      at com.sun.xml.bind.v2.model.impl.FieldPropertySeed.getRawType(FieldPropertySeed.java:74)
      at com.sun.xml.bind.v2.model.impl.RuntimeClassInfoImpl$RuntimePropertySeed.getRawType(RuntimeClassInfoImpl.java:315)
      at com.sun.xml.bind.v2.model.impl.RuntimeClassInfoImpl$RuntimePropertySeed.getRawType(RuntimeClassInfoImpl.java:289)
      at com.sun.xml.bind.v2.model.impl.PropertyInfoImpl.<init>(PropertyInfoImpl.java:119)
      at com.sun.xml.bind.v2.model.impl.ERPropertyInfoImpl.<init>(ERPropertyInfoImpl.java:53)
      at com.sun.xml.bind.v2.model.impl.ElementPropertyInfoImpl.<init>(ElementPropertyInfoImpl.java:96)
      at com.sun.xml.bind.v2.model.impl.RuntimeElementPropertyInfoImpl.<init>(RuntimeElementPropertyInfoImpl.java:59)
      at com.sun.xml.bind.v2.model.impl.RuntimeClassInfoImpl.createElementProperty(RuntimeClassInfoImpl.java:165)
      at com.sun.xml.bind.v2.model.impl.ClassInfoImpl.addProperty(ClassInfoImpl.java:868)
      at com.sun.xml.bind.v2.model.impl.ClassInfoImpl.findFieldProperties(ClassInfoImpl.java:398)
      at com.sun.xml.bind.v2.model.impl.ClassInfoImpl.getProperties(ClassInfoImpl.java:301)
      at com.sun.xml.bind.v2.model.impl.RuntimeClassInfoImpl.getProperties(RuntimeClassInfoImpl.java:176)
      at com.sun.xml.bind.v2.model.impl.ModelBuilder.getClassInfo(ModelBuilder.java:243)
      at com.sun.xml.bind.v2.model.impl.RuntimeModelBuilder.getClassInfo(RuntimeModelBuilder.java:100)
      at com.sun.xml.bind.v2.model.impl.RuntimeModelBuilder.getClassInfo(RuntimeModelBuilder.java:81)
      at com.sun.xml.bind.v2.model.impl.ModelBuilder.getClassInfo(ModelBuilder.java:209)
      at com.sun.xml.bind.v2.model.impl.RuntimeModelBuilder.getClassInfo(RuntimeModelBuilder.java:95)
      at com.sun.xml.bind.v2.model.impl.RuntimeModelBuilder.getClassInfo(RuntimeModelBuilder.java:81)
      at com.sun.xml.bind.v2.model.impl.ModelBuilder.getTypeInfo(ModelBuilder.java:315)
      at com.sun.xml.bind.v2.model.impl.ModelBuilder.getTypeInfo(ModelBuilder.java:330)
      at com.sun.xml.bind.v2.runtime.JAXBContextImpl.getTypeInfoSet(JAXBContextImpl.java:441)
      at com.sun.xml.bind.v2.runtime.JAXBContextImpl.<init>(JAXBContextImpl.java:288)
      at com.sun.xml.bind.v2.runtime.JAXBContextImpl$JAXBContextBuilder.build(JAXBContextImpl.java:1111)
      at com.sun.xml.bind.v2.ContextFactory.createContext(ContextFactory.java:154)
      at com.sun.xml.bind.api.JAXBRIContext.newInstance(JAXBRIContext.java:106)
      at com.sun.xml.ws.developer.JAXBContextFactory$1.createJAXBContext(JAXBContextFactory.java:109)
      at com.sun.xml.ws.model.AbstractSEIModelImpl$1.run(AbstractSEIModelImpl.java:159)
      at com.sun.xml.ws.model.AbstractSEIModelImpl$1.run(AbstractSEIModelImpl.java:152)
      at java.security.AccessController.doPrivileged(Native Method)
      at com.sun.xml.ws.model.AbstractSEIModelImpl.createJAXBContext(AbstractSEIModelImpl.java:151)
      at com.sun.xml.ws.model.AbstractSEIModelImpl.postProcess(AbstractSEIModelImpl.java:94)
      at com.sun.xml.ws.model.RuntimeModeler.buildRuntimeModel(RuntimeModeler.java:255)
      at com.sun.xml.ws.server.EndpointFactory.createSEIModel(EndpointFactory.java:323)
      at com.sun.xml.ws.server.EndpointFactory.createEndpoint(EndpointFactory.java:189)
      at com.sun.xml.ws.api.server.WSEndpoint.create(WSEndpoint.java:467)
      at com.sun.xml.ws.transport.http.DeploymentDescriptorParser.parseAdapters(DeploymentDescriptorParser.java:253)
      at com.sun.xml.ws.transport.http.DeploymentDescriptorParser.parse(DeploymentDescriptorParser.java:147)
      at com.sun.xml.ws.transport.http.servlet.WSServletContextListener.contextInitialized(WSServletContextListener.java:108)
      at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:634)
      at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:228)
      at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1098)
      at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:577)
      at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:483)
      at org.mortbay.jetty.plugin.JettyWebAppContext.doStart(JettyWebAppContext.java:160)
      at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
      at org.eclipse.jetty.server.handler.HandlerCollection$1.run(HandlerCollection.java:200)
      at org.eclipse.jetty.util.thread.QueuedThreadPool$2.run(QueuedThreadPool.java:450)
      at java.lang.Thread.run(Thread.java:680)
      Caused by:
      java.lang.ClassNotFoundException: byte
      at org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy.loadClass(SelfFirstStrategy.java:50)
      at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:244)
      at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:230)
      at org.eclipse.jetty.webapp.WebAppClassLoader.loadClass(WebAppClassLoader.java:428)
      at org.eclipse.jetty.webapp.WebAppClassLoader.loadClass(WebAppClassLoader.java:381)
      at java.lang.Class.forName0(Native Method)
      at java.lang.Class.forName(Class.java:247)
      at sun.reflect.generics.factory.CoreReflectionFactory.makeNamedType(CoreReflectionFactory.java:95)
      at sun.reflect.generics.visitor.Reifier.visitClassTypeSignature(Reifier.java:107)
      at sun.reflect.generics.tree.ClassTypeSignature.accept(ClassTypeSignature.java:31)
      at sun.reflect.generics.visitor.Reifier.visitArrayTypeSignature(Reifier.java:141)
      at sun.reflect.generics.tree.ArrayTypeSignature.accept(ArrayTypeSignature.java:24)
      at sun.reflect.generics.repository.FieldRepository.getGenericType(FieldRepository.java:67)
      at java.lang.reflect.Field.getGenericType(Field.java:223)
      at com.sun.xml.bind.v2.model.nav.ReflectionNavigator.getFieldType(ReflectionNavigator.java:273)
      at com.sun.xml.bind.v2.model.nav.ReflectionNavigator.getFieldType(ReflectionNavigator.java:58)
      at com.sun.xml.bind.v2.model.impl.FieldPropertySeed.getRawType(FieldPropertySeed.java:74)
      at com.sun.xml.bind.v2.model.impl.RuntimeClassInfoImpl$RuntimePropertySeed.getRawType(RuntimeClassInfoImpl.java:315)
      at com.sun.xml.bind.v2.model.impl.RuntimeClassInfoImpl$RuntimePropertySeed.getRawType(RuntimeClassInfoImpl.java:289)
      at com.sun.xml.bind.v2.model.impl.PropertyInfoImpl.<init>(PropertyInfoImpl.java:119)
      at com.sun.xml.bind.v2.model.impl.ERPropertyInfoImpl.<init>(ERPropertyInfoImpl.java:53)
      at com.sun.xml.bind.v2.model.impl.ElementPropertyInfoImpl.<init>(ElementPropertyInfoImpl.java:96)
      at com.sun.xml.bind.v2.model.impl.RuntimeElementPropertyInfoImpl.<init>(RuntimeElementPropertyInfoImpl.java:59)
      at com.sun.xml.bind.v2.model.impl.RuntimeClassInfoImpl.createElementProperty(RuntimeClassInfoImpl.java:165)
      at com.sun.xml.bind.v2.model.impl.ClassInfoImpl.addProperty(ClassInfoImpl.java:868)
      at com.sun.xml.bind.v2.model.impl.ClassInfoImpl.findFieldProperties(ClassInfoImpl.java:398)
      at com.sun.xml.bind.v2.model.impl.ClassInfoImpl.getProperties(ClassInfoImpl.java:301)
      at com.sun.xml.bind.v2.model.impl.RuntimeClassInfoImpl.getProperties(RuntimeClassInfoImpl.java:176)
      at com.sun.xml.bind.v2.model.impl.ModelBuilder.getClassInfo(ModelBuilder.java:243)
      at com.sun.xml.bind.v2.model.impl.RuntimeModelBuilder.getClassInfo(RuntimeModelBuilder.java:100)
      at com.sun.xml.bind.v2.model.impl.RuntimeModelBuilder.getClassInfo(RuntimeModelBuilder.java:81)
      at com.sun.xml.bind.v2.model.impl.ModelBuilder.getClassInfo(ModelBuilder.java:209)
      at com.sun.xml.bind.v2.model.impl.RuntimeModelBuilder.getClassInfo(RuntimeModelBuilder.java:95)
      at com.sun.xml.bind.v2.model.impl.RuntimeModelBuilder.getClassInfo(RuntimeModelBuilder.java:81)
      at com.sun.xml.bind.v2.model.impl.ModelBuilder.getTypeInfo(ModelBuilder.java:315)
      at com.sun.xml.bind.v2.model.impl.ModelBuilder.getTypeInfo(ModelBuilder.java:330)
      at com.sun.xml.bind.v2.runtime.JAXBContextImpl.getTypeInfoSet(JAXBContextImpl.java:441)
      at com.sun.xml.bind.v2.runtime.JAXBContextImpl.<init>(JAXBContextImpl.java:288)
      at com.sun.xml.bind.v2.runtime.JAXBContextImpl$JAXBContextBuilder.build(JAXBContextImpl.java:1111)
      at com.sun.xml.bind.v2.ContextFactory.createContext(ContextFactory.java:154)
      at com.sun.xml.bind.api.JAXBRIContext.newInstance(JAXBRIContext.java:106)
      at com.sun.xml.ws.developer.JAXBContextFactory$1.createJAXBContext(JAXBContextFactory.java:109)
      at com.sun.xml.ws.model.AbstractSEIModelImpl$1.run(AbstractSEIModelImpl.java:159)
      at com.sun.xml.ws.model.AbstractSEIModelImpl$1.run(AbstractSEIModelImpl.java:152)
      at java.security.AccessController.doPrivileged(Native Method)
      at com.sun.xml.ws.model.AbstractSEIModelImpl.createJAXBContext(AbstractSEIModelImpl.java:151)
      at com.sun.xml.ws.model.AbstractSEIModelImpl.postProcess(AbstractSEIModelImpl.java:94)
      at com.sun.xml.ws.model.RuntimeModeler.buildRuntimeModel(RuntimeModeler.java:255)
      at com.sun.xml.ws.server.EndpointFactory.createSEIModel(EndpointFactory.java:323)
      at com.sun.xml.ws.server.EndpointFactory.createEndpoint(EndpointFactory.java:189)
      at com.sun.xml.ws.api.server.WSEndpoint.create(WSEndpoint.java:467)
      at com.sun.xml.ws.transport.http.DeploymentDescriptorParser.parseAdapters(DeploymentDescriptorParser.java:253)
      at com.sun.xml.ws.transport.http.DeploymentDescriptorParser.parse(DeploymentDescriptorParser.java:147)
      at com.sun.xml.ws.transport.http.servlet.WSServletContextListener.contextInitialized(WSServletContextListener.java:108)
      at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:634)
      at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:228)
      at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1098)
      at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:577)
      at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:483)
      at org.mortbay.jetty.plugin.JettyWebAppContext.doStart(JettyWebAppContext.java:160)
      at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
      at org.eclipse.jetty.server.handler.HandlerCollection$1.run(HandlerCollection.java:200)
      at org.eclipse.jetty.util.thread.QueuedThreadPool$2.run(QueuedThreadPool.java:450)
      at java.lang.Thread.run(Thread.java:680)

        Activity

        Jan Bartel added a comment -

        Gordon,

        Does this work in an installed jetty instance (vs running via the plugin)?

        Jan

        Gordon Shannon added a comment -

        Sorry, I don't know. I only use the plugin in our dev environment. If it's easy to do, I could try it.

        Gordon

        Jan Bartel added a comment -

        Gordon,

        Hopefully simple ... download and install jetty from http://download.eclipse.org/jetty/7.4.4.v20110707/dist/.
        Build your project into a war (mvn install should do it).
        Copy your war to $JETTY_HOME/webapps.
        java -jar start.jar

        cheers
        Jan

        Gordon Shannon added a comment -

        Jan,

        Thanks for looking into this! Is there a maven plugin patch also? That's what all our apps use for unit testing and WS proxy class generation.

        gordon

        Jan Bartel added a comment -

        Gordon,

        Sorry, not sure what you mean?? Are you saying you can't configure a jetty installation to do the same thing as you do with the maven jetty plugin?

        thanks
        Jan

        Jan Bartel added a comment -

        Gordon,

        This is almost certainly a WS bug, or one of those circumstances where perhaps mvn jetty:run won't work, and you need to use mvn jetty:run-war instead. If you tried your built webapp on jetty standalone as I posted earlier, then it would help point out where the problem lies.

        I'd like to either progress or close this issue soon, so please let us know if this is resolved, or post us more information that we can work with.

        thanks
        Jan

        Jan Bartel added a comment -

        I can't see any evidence that this is a jetty issue. As there's been no new info on this for a long time, I'm closing it. As always, if new info comes along that points to a jetty problem, please reopen the issue.

        regards
        Jan


          People

          • Assignee:
            Jan Bartel
            Reporter:
            Gordon Shannon
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: