Jetty
  1. Jetty
  2. JETTY-1178

Make continuation servlet to log the incoming JSON in case of parsing errors

    Details

    • Type: New Feature New Feature
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 6.1.22
    • Fix Version/s: 6.1.23
    • Component/s: Bayeux
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Sometimes the JSON parsing throws exceptions similar to this:

      Caused by: java.lang.IllegalStateException: Unexpected '0' while seeking one of ',}'

      or

      Caused by: java.lang.IllegalStateException: Unexpected 'P' while seeking one of ',}'

      and others exception of similar type as well.

      It would be useful to know what is the full input to be able to debug what is going on.

        Activity

        Simone Bordet added a comment -

        Added "jsonDebug" init param to the CometD servlet configuration, so that the input is fully read into a string, and if an error occurs it is fully printed in the exception message.


          People

          • Assignee:
            Simone Bordet
            Reporter:
            Simone Bordet
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: