Jetty
  1. Jetty
  2. JETTY-1060

HttpClient stops to work. I guess it attempts to reuse closed by server connections.

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 7.0.0.pre5
    • Fix Version/s: None
    • Component/s: Client, Servlet
    • Labels:
      None
    • Environment:
      I used modified HttpProxy with jett7
    • Number of attachments :
      0

      Description

      I used modified HttpProxy with jetty as front end for the 2 webservers: amazon S3 and tomcat

      It seems HttpClient attemtps to use connections that expired instead of creating new connections

      I added page to jetty that replaces HttpClient object in servlet with a new instance of HttpClient.

      private void initHttpClient() throws ServletException {
      _client = new HttpClient();
      _client.setConnectorType(HttpClient.CONNECTOR_SOCKET);
      // _client.setConnectorType(HttpClient.CONNECTOR_SELECT_CHANNEL);
      _client.setMaxConnectionsPerAddress(100);
      // _client.setMaxRetries(0);
      try

      { _client.start(); }

      catch (Exception e)

      { throw new ServletException(e); }

      }

      Everytime when I am calling initHttpClient() method HttpProxy starts to work again for some time.

      Both SOCKET and SELECT versions are affected

      It happens after some unpredictable period of time: 30 minutes or 6 hours.

        Activity

        Greg Wilkins added a comment -

        Max,

        7.0.0.pre5 is an old early release of jetty-7 It has many bugs that have since been fixed.

        Can you try the latest jetty 7.0.0.M? release from http://eclipse.org/jetty

        cheers

        Max added a comment -

        We will test it with M3.

        Max added a comment -

        I failed to reproduce it with M3.

        query server
        restart server
        query server again

        May be it should be closed until I will know how to reproduce it.

        Thank you, Max

        Jan Bartel added a comment -

        Not able to be reproduced with jetty-7.0.0.0.M3. Closing until/unless more info becomes available.

        Jan Bartel made changes -
        Field Original Value New Value
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Cannot Reproduce [ 5 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Max
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: