You are right, isWhitespace is not an appropriate method name anymore, containsQuotableChar is a better name.
Writing an object like this :
items: new Ext.TabPanel(
looks better that :
and not only ExtJS skips quoting keys, jQuery and other JS libraries.
This library could use by default quotes, but it should have an option to turn on an automatic quotes. Hypen seems to be a special character, if is present quotes must be present.