JavaNCSS
  1. JavaNCSS
  2. JAVANCSS-19

-recursive never ends on directory without java source files

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 30.51
    • Fix Version/s: 32.53
    • Labels:
      None
    • Number of attachments :
      0

      Description

      From Guilherme J.:

      ===
      if I run the program recursively for one directory that does not contain any java source, is it supposed to output any message warning me of that? I am asking this because I had problems "waiting" for the program that would never exit!

      I don't know if this is a feature or a bug
      ===

      Confirmed, it is a bug and has nothing todo with recursive links or something like that.

        Issue Links

          Activity

          Herve Boutemy added a comment -

          fixed in r156
          in case no file was found, javancss was trying to parse stdin
          but if called with "-recursive" option, such a behaviour was not expected


            People

            • Assignee:
              Herve Boutemy
              Reporter:
              Clemens Lee
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: