IzPack
  1. IzPack
  2. IZPACK-647

Unable to launch wizard (panel) after creating the setup.exe in windows 7

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 4.3.3
    • Fix Version/s: 4.3.4, 5.0
    • Component/s: Native launcher
    • Labels:
      None
    • Environment:
      Windows 7
    • Number of attachments :
      1

      Description

      I am trying to create SFX image for jar from the IZPACK installer in windows7 for win 32 machines.

      How i created : executed the below commands
      compile install.xml -k web
      izpack2exe --file=install.jar

      Result : Setup.exe will be created.

      problem : Double click on the setup.exe will just extract and explore the files of exe instead of showing setup wizards

        Activity

        Julien Ponge added a comment -

        Check that the target operating system has a working Java installation. More specifically, check that opening a Jar file does not trigger some weird compressed file management program.

        Timothy Fridey added a comment -

        This is a duplicate of IZPACK-560 and IZPACK-30

        I had a bit of a play today, I never knew python could create executable files for windows, was a pleasant surprise. I'm not sure what the reason is for 7zipping the jar since it is already compressed.

        Anyway, I have a patch for this issue that I have tested on WinXP and Win7. It works the same in every other way that I can tell. However I uncovered another bug in Win7 (not caused by my fix, is in current version also where the install crashes if there are any execution parameters e.g. --launch-args ) I will open a new issue for this bug, just though you should be aware its not caused by my fix.

        Timothy Fridey added a comment -

        Until I can work out how to create a patch in git here is the whole file.

        The change is:
        config.write('ExecuteFile="javaw"')
        config.write('ExecuteParameters="-jar \\\"%s\\\"' % filename)
        if settings.launchargs != '':
        config.write(' %s"\r\n' % settings.launchargs)
        else:
        config.write('"\r\n')

        Julien Ponge added a comment -

        It's in, thanks!


          People

          • Assignee:
            Unassigned
            Reporter:
            vinay
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: