IzPack
  1. IzPack
  2. IZPACK-613

maven-plugin fails with unsatisfied dependency

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 5.0
    • Fix Version/s: 5.0
    • Component/s: None
    • Labels:
      None
    • Environment:
      Windows 7 x64, Eclipse 3.6, Maven 2.2.1 (also tried 3.0-latest snapshot), izPack-5.0-beta1
    • Number of attachments :
      1

      Description

      When trying to compile with the attached POM, I always get this: (4.3 worked)

      [INFO] Scanning for projects...
      [WARNING]
      [WARNING] Some problems were encountered while building the effective model for at.sozvers.seucc:ta30j-referenzinstallation:pom:3.5.2_0.8.0
      [WARNING] 'repositories.repository.layout = legacy' is deprecated: Hastings-Maven1-Repo @ at.sozvers.seucc:ta30j-referenzinstallation:3.5.2_0.8.0, C:\ta30\Projekte\eclipse_ri\ta30j-referenzinstallation\pom.xml
      [WARNING]
      [WARNING] It is highly recommended to fix these problems because they threaten the stability of your build.
      [WARNING]
      [WARNING] For this reason, future Maven versions might no longer support building such malformed projects.
      [WARNING]
      [INFO]
      [INFO] ------------------------------------------------------------------------
      [INFO] Building TA3.0J Referenzinstallation 3.5.2_0.8.0
      [INFO] ------------------------------------------------------------------------
      [INFO]
      [INFO] — maven-resources-plugin:2.4.3:copy-resources (copy-resources) @ ta30j-referenzinstallation —
      [INFO] Using 'UTF-8' encoding to copy filtered resources.
      [INFO] Copying 25 resources
      [INFO]
      [INFO] — izpack-maven-plugin:5.0.0-beta1:izpack (default) @ ta30j-referenzinstallation —
      [WARNING] Using platform encoding (UTF-8 actually) to copy filtered resources, i.e. build is platform dependent!
      [INFO] Copying 0 resource
      org.apache.maven.plugin.MojoExecutionException: IzPack compilation ERROR
      at org.izpack.mojo.IzPackMojo.buildInstaller(IzPackMojo.java:280)
      at org.izpack.mojo.IzPackMojo.execute(IzPackMojo.java:173)
      at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:105)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:577)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:324)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:247)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:104)
      at org.apache.maven.cli.MavenCli.execute(MavenCli.java:427)
      at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:157)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:121)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
      at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
      at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
      at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
      Caused by: org.picocontainer.injectors.AbstractInjector$UnsatisfiableDependenciesException: com.izforge.izpack.compiler.helper.AssertionHelper has unsatisfied dependency: class java.lang.String among unsatisfiable dependencies: [[class java.lang.String]] where org.picocontainer.DefaultPicoContainer@512d8ecd:25<(empty) was the leaf container being asked for dependencies.
      at org.picocontainer.injectors.ConstructorInjector.getGreediestSatisfiableConstructor(ConstructorInjector.java:188)
      at org.picocontainer.injectors.ConstructorInjector.getGreediestSatisfiableConstructor(ConstructorInjector.java:110)
      at org.picocontainer.injectors.ConstructorInjector.access$100(ConstructorInjector.java:51)
      at org.picocontainer.injectors.ConstructorInjector$1.run(ConstructorInjector.java:308)
      at org.picocontainer.injectors.AbstractInjector$ThreadLocalCyclicDependencyGuard.observe(AbstractInjector.java:274)
      at org.picocontainer.injectors.ConstructorInjector.getComponentInstance(ConstructorInjector.java:341)
      at org.picocontainer.behaviors.AbstractBehavior.getComponentInstance(AbstractBehavior.java:64)
      at org.picocontainer.behaviors.Stored.getComponentInstance(Stored.java:91)
      at org.picocontainer.DefaultPicoContainer.getInstance(DefaultPicoContainer.java:692)
      at org.picocontainer.DefaultPicoContainer.getComponent(DefaultPicoContainer.java:641)
      at org.picocontainer.DefaultPicoContainer.getComponent(DefaultPicoContainer.java:630)
      at org.picocontainer.parameters.BasicComponentParameter$1.resolveInstance(BasicComponentParameter.java:105)
      at org.picocontainer.parameters.ComponentParameter$1.resolveInstance(ComponentParameter.java:136)
      at org.picocontainer.injectors.SingleMemberInjector.getParameter(SingleMemberInjector.java:76)
      at org.picocontainer.injectors.ConstructorInjector$CtorAndAdapters.getParameterArguments(ConstructorInjector.java:286)
      at org.picocontainer.injectors.ConstructorInjector$1.run(ConstructorInjector.java:312)
      at org.picocontainer.injectors.AbstractInjector$ThreadLocalCyclicDependencyGuard.observe(AbstractInjector.java:274)
      at org.picocontainer.injectors.ConstructorInjector.getComponentInstance(ConstructorInjector.java:341)
      at org.picocontainer.behaviors.AbstractBehavior.getComponentInstance(AbstractBehavior.java:64)
      at org.picocontainer.behaviors.Stored.getComponentInstance(Stored.java:91)
      at org.picocontainer.DefaultPicoContainer.getInstance(DefaultPicoContainer.java:692)
      at org.picocontainer.DefaultPicoContainer.getComponent(DefaultPicoContainer.java:641)
      at org.picocontainer.DefaultPicoContainer.getComponent(DefaultPicoContainer.java:630)
      at org.picocontainer.parameters.BasicComponentParameter$1.resolveInstance(BasicComponentParameter.java:105)
      at org.picocontainer.parameters.ComponentParameter$1.resolveInstance(ComponentParameter.java:136)
      at org.picocontainer.injectors.SingleMemberInjector.getParameter(SingleMemberInjector.java:76)
      at org.picocontainer.injectors.ConstructorInjector$CtorAndAdapters.getParameterArguments(ConstructorInjector.java:286)
      at org.picocontainer.injectors.ConstructorInjector$1.run(ConstructorInjector.java:312)
      at org.picocontainer.injectors.AbstractInjector$ThreadLocalCyclicDependencyGuard.observe(AbstractInjector.java:274)
      at org.picocontainer.injectors.ConstructorInjector.getComponentInstance(ConstructorInjector.java:341)
      at org.picocontainer.behaviors.AbstractBehavior.getComponentInstance(AbstractBehavior.java:64)
      at org.picocontainer.behaviors.Stored.getComponentInstance(Stored.java:91)
      at org.picocontainer.DefaultPicoContainer.getInstance(DefaultPicoContainer.java:692)
      at org.picocontainer.DefaultPicoContainer.getComponent(DefaultPicoContainer.java:641)
      at org.picocontainer.DefaultPicoContainer.getComponent(DefaultPicoContainer.java:630)
      at org.picocontainer.parameters.BasicComponentParameter$1.resolveInstance(BasicComponentParameter.java:105)
      at org.picocontainer.parameters.ComponentParameter$1.resolveInstance(ComponentParameter.java:136)
      at org.picocontainer.injectors.SingleMemberInjector.getParameter(SingleMemberInjector.java:76)
      at org.picocontainer.injectors.ConstructorInjector$CtorAndAdapters.getParameterArguments(ConstructorInjector.java:286)
      at org.picocontainer.injectors.ConstructorInjector$1.run(ConstructorInjector.java:312)
      at org.picocontainer.injectors.AbstractInjector$ThreadLocalCyclicDependencyGuard.observe(AbstractInjector.java:274)
      at org.picocontainer.injectors.ConstructorInjector.getComponentInstance(ConstructorInjector.java:341)
      at org.picocontainer.behaviors.AbstractBehavior.getComponentInstance(AbstractBehavior.java:64)
      at org.picocontainer.behaviors.Stored.getComponentInstance(Stored.java:91)
      at org.picocontainer.DefaultPicoContainer.getInstance(DefaultPicoContainer.java:692)
      at org.picocontainer.DefaultPicoContainer.getComponent(DefaultPicoContainer.java:641)
      at org.picocontainer.DefaultPicoContainer.getComponent(DefaultPicoContainer.java:666)
      at com.izforge.izpack.core.container.AbstractContainer.getComponent(AbstractContainer.java:40)
      at org.izpack.mojo.IzPackMojo.buildInstaller(IzPackMojo.java:268)
      ... 17 more
      [INFO]
      [INFO] — maven-install-plugin:2.3:install (default-install) @ ta30j-referenzinstallation —
      [INFO] Installing C:\ta30\Projekte\eclipse_ri\ta30j-referenzinstallation\pom.xml to C:\Users\rosenauer\.m2\repository\at\sozvers\seucc\ta30j-referenzinstallation\3.5.2_0.8.0\ta30j-referenzinstallation-3.5.2_0.8.0.pom
      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD SUCCESS
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 2.423s
      [INFO] Finished at: Thu Sep 16 12:59:31 CEST 2010
      [INFO] Final Memory: 6M/143M
      [INFO] ------------------------------------------------------------------------

      1. pom.xml
        4 kB
        Gregor B. Rosenauer

        Activity

        Anthonin Bonnefoy added a comment -

        The problem was due to some remains of non-functional maven plugin.
        The new maven plugin is now called with the "izpack" goal (instead of the unknown "compile" goal) and thus replace the old plugin.


          People

          • Assignee:
            Anthonin Bonnefoy
            Reporter:
            Gregor B. Rosenauer
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: