IzPack
  1. IzPack
  2. IZPACK-596

Ubuntu 10+ needs .desktop files to be executable

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.3.3
    • Fix Version/s: 4.3.4, 5.0
    • Component/s: Installer
    • Labels:
      None
    • Environment:
      Ubuntu 10.04 at least is affected.

      Description

      Creating desktop shortcuts on Ubuntu doesn't work. The following error is shown:
      Untrusted application launcher: The application launcher "Browse-Freenet-1278868750884.desktop" has not been marked as trusted. If you do not know the source of this file, launching it may be unsafe.

      Ubuntu people tell me this is simply caused by the .desktop items not being +x.

      I have attached a patch but unfortunately I have not been able to build from source yet, so I cannot guarantee that it works. It is however trivial.

        Activity

        Julien Ponge added a comment -

        Thanks!


          People

          • Assignee:
            Julien Ponge
            Reporter:
            Matthew John Toseland
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: