IzPack
  1. IzPack
  2. IZPACK-567

FinishPanel (SimpleFinishPanel) repaint

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 4.3.3
    • Fix Version/s: 4.3.4, 5.0
    • Component/s: Panels
    • Labels:
      None
    • Environment:
      Windows XP, Linux Ubuntu 9.10
    • Number of attachments :
      2

      Description

      Very often is not SimpleFinishPanel painted successfully. Text is not painted at the first moment, but later: in the moment of resizing the panel (by the mouse).
      It never happened with 4.3.1.
      (With installation/guiprefs/laf "substance" on Windows it works OK, but not on Linux. Strange.)

      1. FinishPanel.java.patch
        2 kB
        Stuart Wallis
      2. SimpleFinishPanel.java.patch
        3 kB
        Stuart Wallis

        Activity

        Julien Ponge added a comment -

        This looks like a Look and Feel issue.

        David Duponchel added a comment -

        It seems that Anthonin has solved this issue, see http://old.nabble.com/Empty-FinishPanel-td27769884.html#a27901352
        Those changes are already on the master repository, so this issue should be fixed in IzPack 5.

        Mark Miller added a comment -

        I have backported a fix for this off 4.3.3 here:
        https://github.com/lucidimagination/izpack/commit/418de508a67a14dfc7413ddb319c7418c0c18664

        The spacing is a little wonky - I tried to fix it a bit, but could still be better. Not sure if this is a problem in 5 (as I cannot get 5 working), but the layout spacing was bad with a straight port of the code.

        Stuart Wallis added a comment -

        Patch for SimpleFinishPanel.java (from 4.3.3)

        Stuart Wallis added a comment -

        Patch for FinishPanel.java based on Mark Miller's changes with better layout (IMO) from 4.3.3 source

        Earl Hood added a comment -

        Blank SimpleFinishPanel happens under IzPack 4.3.4 under Windows 7.
        When I resize the panel with the mouse, the text finally appears.

        Running java 1.6.0_26 on 32bit Windows 7.

        bflorat added a comment -

        This is not fixed in 4.3.5 at least under Seven 64 bits[1], JRE Oracle 7.

        SimpleFinishPanel text only appears when resizing the dialog. Several users reported it on my own application, they think that the application is not installed (it is a strong issue for us).

        [1] I already experienced this randomly under XP and maybe Seven 32 bits but it is always reproducible under Seven 64 bits for some reasons.

        I found a workaround : using FinishPanel instead of SimpleFinishPanel works for me all the time (10 launches so far).

        Martin Ždila added a comment -

        workaround is to add following line at the end of panelActivate method:

        parent.setSize(parent.getWidth() + 1, parent.getHeight());


          People

          • Assignee:
            Julien Ponge
            Reporter:
            Roman Musil
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: