Haus Chores
  1. Haus Chores
  2. HAUS-2113

Code samples are invisible since the latest Confluence upgrade

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Confluence
    • Labels:
      None
    • Number of attachments :
      0

      Description

      The code examples as for example on http://groovy.codehaus.org/Process+Management are invisible. Actually I wuld have thought this is the same as HAUS-2112, but sine that one is closed and it does still not work for us, I would assume it is a different case.

      Since we have a lot of code driven user guides (Groovy is a programming language after all) on our pages, and since those samples are usually the part people looking for, this is somewhat critical

        Activity

        Ben Walding added a comment -

        It's the same issue. You have customised templates; I'll update your templates when Confluence comes back online - new version - new bugs.

        Ben Walding added a comment -

        jQuery syntax fixer added:

        <script type='text/javascript'>
          jQuery(function() {
            jQuery.fixSyntaxBlocks = function() {
              var i;
              var ccs = jQuery('div.codeContent');
        
              for (i = 0; i < ccs.length; i++) {
                var cc = jQuery(ccs[i]);
                var script = cc.find('script');
                var pre = jQuery('<pre/>');
        
                var content = script.text();
                content = content.substring(9, content.length - 3);
                pre.html(content);
        
                cc.remove('script');
                cc.append(pre);
              }
            };
            jQuery.fixSyntaxBlocks();
          });
        </script>
        
        blackdrag blackdrag added a comment -

        thanks, looks like the issue is fixed here

        Ben Walding added a comment -

        I'm not super-duper-happy with the solution - but fixing it in the Codehaus renderer takes a bit of effort.

        I will have a look at doing that, as it removes the javascript requirement.


          People

          • Assignee:
            Ben Walding
            Reporter:
            blackdrag blackdrag
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: