groovy
  1. groovy
  2. GROOVY-901

SimpleTemplateEngine error :"Caught: Script1.groovy: 1: expecting anything but ''\n''; got it anyway @ line"

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0-JSR-2
    • Fix Version/s: 1.0-JSR-3
    • Component/s: groovy-jdk
    • Labels:
      None
    • Environment:
      jdk 1.5.0_02, Windows XP Sp2,Groovy 1.0-JSR-2
    • Number of attachments :
      2

      Description

      Simple program, but the result surprised me.
      The template should WYSIWYG, but in this version of SimpleTemplateEngine of Groovy, all text must be written in one row and must use "\n" instead of an enter press.
      I think this should be a bug.

      attachment is the simple program and template file it uses.

      1. template.txt
        0.1 kB
        Alan L Zhang
      2. templateEngine.groovy
        0.3 kB
        Alan L Zhang

        Issue Links

          Activity

          Christian Stein added a comment -

          Already stumbled across it - couldn't reproduce it that time. Looking into it now.
          The TemplateServlet uses a work-around at the moment, eliminating all '\n' before compiling.

          Christian Stein added a comment -

          SimpleTemplateEngine correctly handles new line characters now.


            People

            • Assignee:
              Christian Stein
              Reporter:
              Alan L Zhang
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: