groovy
  1. groovy
  2. GROOVY-804

Stacktrace when upgrading to #3281

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.0-beta-10
    • Fix Version/s: 1.0-JSR-2
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Original exception: com.intellij.lang.Language.findByID(Ljava/lang/String;)Lcom/intellij/lang/Language;
      java.lang.NoSuchMethodError: com.intellij.lang.Language.findByID(Ljava/lang/String;)Lcom/intellij/lang/Language;
      at org.codehaus.groovy.intellij.language.GroovyLanguage.createLanguage(GroovyLanguage.java:37)
      at org.codehaus.groovy.intellij.GroovySupportLoader.<clinit>(GroovySupportLoader.java:30)
      at java.lang.Class.forName0(Native Method)
      at java.lang.Class.forName(Class.java:219)
      at com.intellij.openapi.components.impl.ComponentManagerImpl.loadComponentsConfiguration(ComponentManagerImpl.java:222)
      at com.intellij.openapi.application.impl.ApplicationImpl.c(ApplicationImpl.java:353)
      at com.intellij.openapi.application.impl.ApplicationImpl.<init>(ApplicationImpl.java:279)
      at com.intellij.openapi.application.ex.ApplicationManagerEx.createApplication(ApplicationManagerEx.java:1)
      at com.intellij.idea.IdeaApplication.<init>(IdeaApplication.java:3)
      at com.intellij.idea.Main.a(Main.java:47)
      at com.intellij.idea.Main.access$000(Main.java:25)
      at com.intellij.idea.Main$2.proceed(Main.java)
      at com.intellij.ide.license.impl.IdeaLicense$1.proceed(IdeaLicense.java:3)
      at com.intellij.ide.license.policy.Proceed.check(Proceed.java:1)
      at com.intellij.ide.license.impl.LicenseAuthorizorImpl.checkPolicy(LicenseAuthorizorImpl.java:7)
      at com.intellij.ide.license.impl.LicenseAuthorizorImpl.checkPolicy(LicenseAuthorizorImpl.java:4)
      at com.intellij.ide.license.impl.IdeaLicense.startUp(IdeaLicense.java:22)
      at com.intellij.idea.Main.mainImpl(Main.java:3)
      at com.intellij.idea.Main.start(Main.java:43)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:324)
      at com.intellij.ide.plugins.PluginManager$5.run(PluginManager.java:7)
      at java.lang.Thread.run(Thread.java:534)

      com.intellij.diagnostic.PluginException: com.intellij.lang.Language.findByID(Ljava/lang/String;)Lcom/intellij/lang/Language; [Plugin: Groovy Integration]
      at com.intellij.openapi.components.impl.ComponentManagerImpl.loadComponentsConfiguration(ComponentManagerImpl.java:171)
      at com.intellij.openapi.application.impl.ApplicationImpl.c(ApplicationImpl.java:353)
      at com.intellij.openapi.application.impl.ApplicationImpl.<init>(ApplicationImpl.java:279)
      at com.intellij.openapi.application.ex.ApplicationManagerEx.createApplication(ApplicationManagerEx.java:1)
      at com.intellij.idea.IdeaApplication.<init>(IdeaApplication.java:3)
      at com.intellij.idea.Main.a(Main.java:47)
      at com.intellij.idea.Main.access$000(Main.java:25)
      at com.intellij.idea.Main$2.proceed(Main.java)
      at com.intellij.ide.license.impl.IdeaLicense$1.proceed(IdeaLicense.java:3)
      at com.intellij.ide.license.policy.Proceed.check(Proceed.java:1)
      at com.intellij.ide.license.impl.LicenseAuthorizorImpl.checkPolicy(LicenseAuthorizorImpl.java:7)
      at com.intellij.ide.license.impl.LicenseAuthorizorImpl.checkPolicy(LicenseAuthorizorImpl.java:4)
      at com.intellij.ide.license.impl.IdeaLicense.startUp(IdeaLicense.java:22)
      at com.intellij.idea.Main.mainImpl(Main.java:3)
      at com.intellij.idea.Main.start(Main.java:43)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:324)
      at com.intellij.ide.plugins.PluginManager$5.run(PluginManager.java:7)
      at java.lang.Thread.run(Thread.java:534)
      Caused by: java.lang.NoSuchMethodError: com.intellij.lang.Language.findByID(Ljava/lang/String;)Lcom/intellij/lang/Language;
      at org.codehaus.groovy.intellij.language.GroovyLanguage.createLanguage(GroovyLanguage.java:37)
      at org.codehaus.groovy.intellij.GroovySupportLoader.<clinit>(GroovySupportLoader.java:30)
      at java.lang.Class.forName0(Native Method)
      at java.lang.Class.forName(Class.java:219)
      at com.intellij.openapi.components.impl.ComponentManagerImpl.loadComponentsConfiguration(ComponentManagerImpl.java:222)
      ... 20 more

        Activity

        Franck Rasolo added a comment -

        That's what happens when trying unsupported combinations...

        Will be fixed asap!

        Franck Rasolo added a comment -

        The version of GroovyJ that this bug was reported against has since been superceded.


          People

          • Assignee:
            Franck Rasolo
            Reporter:
            Guillaume Laforge
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: