Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.8.5, 1.8.6
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      window 7, Linux
    • Number of attachments :
      0

      Description

      class MyInnerClass {
        static int myStaticInt = 3;
      }
      
      return MyInnerClass.myStaticInt;
      

      will return 0

      this works fine for short and long (and everything else). it also works if you have to evaluate the value like 3+1-1.
      this also works in 1.8.4 but not later versions

        Activity

        Guillaume Laforge added a comment -

        I looked at some recent version of Groovy (2.0.0) and couldn't reproduce the issue.

        Please reopen if this is still impacting you.


          People

          • Assignee:
            Guillaume Laforge
            Reporter:
            Travis Hyink
          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: