groovy
  1. groovy
  2. GROOVY-5128

Installing Groovy on Windows XP

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Not A Bug
    • Affects Version/s: 1.8.4
    • Fix Version/s: None
    • Component/s: None
    • Environment:
      Windows XP
    • Number of attachments :
      0

      Description

      I installed Groovy-1.8.4 using the window installer. I then launched the Groovy Console and typed in groovy -version, groovy -v, and groovysh and each time I get an exception error. I have my JAVA_HOME variable set, I have my GROOVY_HOME variable set, but the console cannot move past this issue. I can execute Math(16).sqrt, and println commands, etc.

      Can someone tell me what to do to make sure that my installation of Groovy is working correctly? I am following "Progamming Groovy" book published by the Pragmatic Programmers.

      Thanks

        Activity

        John Wagenleitner added a comment -

        The Groovy Console (groovyConsole.bat) only understands Groovy syntax. The commands you referenced as a problem need to be run at the Windows command prompt.

        c:\Java\groovy-1.8.4>bin\groovy -version
        Groovy Version: 1.8.4 JVM: 1.6.0_27
        
        c:\Java\groovy-1.8.4>bin\groovy -v
        Groovy Version: 1.8.4 JVM: 1.6.0_27
        
        c:\Java\groovy-1.8.4>bin\groovysh
        Groovy Shell (1.8.4, JVM: 1.6.0_27)
        Type 'help' or '\h' for help.
        ------------------------------------------
        groovy:000> exit
        
        c:\Java\groovy-1.8.4>
        
        Pascal Schumacher added a comment -

        I guess this should be closed as "Not a Bug".

        Paul King added a comment -

        As per previous comments, if you can execute "Math(16).sqrt, and println etc" then your installation appears to be working. Using "groovy -v" etc. work from the commandline not the shell.


          People

          • Assignee:
            Paul King
            Reporter:
            serious
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: