groovy
  1. groovy
  2. GROOVY-4966

VeryifyError in multi-dimensional array usage: Incompatible argument to function

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.8.0
    • Fix Version/s: 1.8.5, 2.0-beta-2
    • Component/s: None
    • Labels:
      None
    • Environment:
      Mac OSX 10.7, jdk 1.6.0_26-b03-383-11A511
    • Testcase included:
      yes
    • Number of attachments :
      0

      Description

      When running this code, I get the attached error. Please see: http://pastie.org/2327875. Dropping back to 1.7 seems to work. I'm running 1.8.1, but the problem also exists in 1.8.0.

        Activity

        Roshan Dawrani made changes -
        Field Original Value New Value
        Summary VeryifyError in GroovyTestCase: Incompatible argument to function VeryifyError in multi-dimensional array usage: Incompatible argument to function
        Roshan Dawrani made changes -
        Assignee Roshan Dawrani [ roshandawrani ]
        Roshan Dawrani made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 2.0-beta-2 [ 18072 ]
        Fix Version/s 1.8.5 [ 18071 ]
        Resolution Fixed [ 1 ]
        Paul King made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            Roshan Dawrani
            Reporter:
            Chris
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: