Details

    • Type: Task Task
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.8.0
    • Fix Version/s: 1.8.0
    • Component/s: None
    • Labels:
      None
    • Environment:
      RPM based install for groovy 1.8.0
    • Number of attachments :
      1

      Description

      Was in need of a Groovy 1.8.0 rpm based install. Could not find one after v1.5.8. I took the v1.5.8 spec file and turned it into a 1.8.0 and added a dependency on java-devel >= 1.6.0. Placed the rpm on a site I own at this location http://www.it-speeltuin.eu/files/groovy-1.8.0-mso1.rpm.

      (If this is the wrong place or wrong way to do this kind of things, please advise me)

        Activity

        Hide
        Huub Daems added a comment -

        I think I have resolved this issue.

        Show
        Huub Daems added a comment - I think I have resolved this issue.
        Hide
        Guillaume Laforge added a comment -

        Out of curiosity, could I have a look at the .spec file and/or a source rpm?

        Show
        Guillaume Laforge added a comment - Out of curiosity, could I have a look at the .spec file and/or a source rpm?
        Hide
        Huub Daems added a comment -

        This is the spec file I used. The 'source' file is the downloaded groovy zip file: groovy-binary-1.8.0.zip.

        Show
        Huub Daems added a comment - This is the spec file I used. The 'source' file is the downloaded groovy zip file: groovy-binary-1.8.0.zip.
        Hide
        Guillaume Laforge added a comment -

        Thanks!

        Show
        Guillaume Laforge added a comment - Thanks!
        Hide
        Henri Gomez added a comment -

        So it's a rpm built directly from binary package (groovy-binary-1.8.0.zip) ?

        Take care about :

        Requires: java >= 1.6.0

        Take a look at Jenkins spec file comments here :

        https://github.com/jenkinsci/jenkins/blob/master/rpm/SPECS/jenkins.spec

        Show
        Henri Gomez added a comment - So it's a rpm built directly from binary package (groovy-binary-1.8.0.zip) ? Take care about : Requires: java >= 1.6.0 Take a look at Jenkins spec file comments here : https://github.com/jenkinsci/jenkins/blob/master/rpm/SPECS/jenkins.spec
        Hide
        Huub Daems added a comment -

        I only had to replace the groovy-bin-1.5.8.zip with the groovy-binary-1.8.0.zip in the original .spec file to make it work. This is the first rpm I ever build so I needed/used a sample/reference.
        I have read the jenkins spec file. But now there is the choose to either use the Requires: java-devel >= 1:1.6.0 or not to use it all.
        Maybe I would have to make a second rpm with no dependencies on installed java version. Something like groovy-1.8.0-nodep1.rpm. Any voters?

        Show
        Huub Daems added a comment - I only had to replace the groovy-bin-1.5.8.zip with the groovy-binary-1.8.0.zip in the original .spec file to make it work. This is the first rpm I ever build so I needed/used a sample/reference. I have read the jenkins spec file. But now there is the choose to either use the Requires: java-devel >= 1:1.6.0 or not to use it all. Maybe I would have to make a second rpm with no dependencies on installed java version. Something like groovy-1.8.0-nodep1.rpm. Any voters?
        Hide
        Huub Daems added a comment -

        Created another rpm without the Requires on java-devel. It can be found here http://www.it-speeltuin.eu/files/groovy-1.8.0-nodep1.noarch.rpm

        Show
        Huub Daems added a comment - Created another rpm without the Requires on java-devel. It can be found here http://www.it-speeltuin.eu/files/groovy-1.8.0-nodep1.noarch.rpm
        Hide
        Henri Gomez added a comment -

        java-devel requires should be set only if Groovy runtime need JDK (ie: javac/tools.jar) and won't works with just JRE.

        Show
        Henri Gomez added a comment - java-devel requires should be set only if Groovy runtime need JDK (ie: javac/tools.jar) and won't works with just JRE.
        Hide
        Huub Daems added a comment -

        A JDK is required to run Groovy as stated on http://groovy.codehaus.org/Installing+Groovy. Having both gives options to unknown situations.

        Show
        Huub Daems added a comment - A JDK is required to run Groovy as stated on http://groovy.codehaus.org/Installing+Groovy . Having both gives options to unknown situations.

          People

          • Assignee:
            Unassigned
            Reporter:
            Huub Daems
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: