Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.8-rc-4
    • Component/s: SQL processing
    • Labels:
      None
    • Testcase included:
      yes
    • Patch Submitted:
      Yes
    • Number of attachments :
      1

      Issue Links

        Activity

        David Durham added a comment -

        just realized that the patches from 4772 and 4771 probably won't work independently of each other, and I'm not sure how to fix it correctly. This patch has the new GString methods from 4771 in addition to javadoc comments. If someone can describe to me the method to provide these patch correctly, I'll do the work.

        blackdrag blackdrag added a comment -

        here you should have the javadoc for the existing methods only, GROOVY-4771 should have the new methods plus the javadoc for them, plus the addition of the class comment, since that is about paging as well. I should have said so on the list right away, sorry.

        Paul King added a comment -

        If you don't get time to attach new patches, I will try to apply both and "roll back half" i.e. the non-relevant bits. If that turns out to be a bigger job than I expect I will comment back here.

        David Durham added a comment -

        The patch in GROOVY-4772 also includes the changes in GROOVY-4771, I wasn't sure how to generate them separately. If it's important, I will try to regenerate the patches per Jochen's comment, though I may not get it exactly correct with respect to line numbers in the second patch file (caused by both of my patches going against the SVN HEAD version, rather than the version containing my first patch)

        Paul King added a comment -

        Applied in trunk and 1.8 - thanks for the patch(es)


          People

          • Assignee:
            Paul King
            Reporter:
            David Durham
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: