groovy
  1. groovy
  2. GROOVY-3769

Groovy Console hangs if script is executed in rapid succession

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.7-beta-2
    • Fix Version/s: None
    • Component/s: Groovy Console
    • Labels:
      None
    • Environment:
      Mac OS 10.6.1
      Java 1.6.0_15
    • Number of attachments :
      0

      Description

      Click the Run button as fast as you can (or press the shortcut), and soon the "Groovy executing" window will stay forever. Sometimes it's possible to interrupt the script or close the window, sometimes not. Seems to work with any script. For example:

      println "hi"
      

        Activity

        Peter Niederwieser added a comment - - edited

        This also frequently happens when keeping the Groovy console open in the background. Once I switch back to the console, I suddenly get the "Groovy executing" dialog. To get rid of this dialog, I need to quit and restart the Groovy console.

        Pascal Schumacher added a comment -

        I could not reproduce this using Groovy 2.0.6 on Windows XP SP3.

        Even if I keep "Control-R" pressed the console responds after all executions are finished.

        Peter Niederwieser added a comment -

        Can't reproduce with latest Mac OS, Java, and Groovy. Definitely was a problem in September 2009.


          People

          • Assignee:
            blackdrag blackdrag
            Reporter:
            Peter Niederwieser
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: