groovy
  1. groovy
  2. GROOVY-3197

change CliBuilder to be independent of CommonsCLI

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.7.2
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      It seems foreseeable that we have to get away from the outdated commons cli 1.1. This move creates a problem for this builder, because for one I think it is good to have such a builder, but for two it is a big hazzle to depend on a broken lib. Therefor the builder should be modified or maybe deprecated/replaced. It would be nice if the builder could work together with a number of command line interfaces, but if there is a new builder, then it should try not to expose the underlaying cli lib too much, allowing us to replace the lib easily. Also the builder is used for example by gant, so a simple removal is probably out of question

        Activity

          People

          • Assignee:
            Unassigned
            Reporter:
            blackdrag blackdrag
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: