groovy
  1. groovy
  2. GROOVY-2019

Editable columns shuld default to no-editable for read only attributes

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Incomplete
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      The parent bug allowed for declaring arbitrary editing state to any property, even if the property is read-only. This task is to make the default editability be false if there is no setter in the appropriate property, and either ignore a true editability request or throw an error when it is explicitly set.

        Activity

        blackdrag blackdrag added a comment -

        Danno, can you give an example that makes it more reproducable for us?

        blackdrag blackdrag added a comment -

        I am closing this issue for now, since Danno does currently not contribute and since nobody else seems to know what this issue is really about


          People

          • Assignee:
            blackdrag blackdrag
            Reporter:
            Danno Ferrin
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: