groovy
  1. groovy
  2. GROOVY-1866

Extend Closure coercion to classes

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 1.1-rc-3
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Currently, it is possible to define closure coercion to interfaces:

      { } as Runnable

      (bad example since closures are already runnable, but still...)

      The mechanism leverages Java proxies and invocation handlers.
      The mechanism should be enhanced to allow extending classes as well.

        Activity

        blackdrag blackdrag added a comment -

        duplicate of GROOVY-1724


          People

          • Assignee:
            blackdrag blackdrag
            Reporter:
            Guillaume Laforge
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: