groovy
  1. groovy
  2. GROOVY-1712

Source and test reorganization and Groovy core / gdk artifacts

    Details

    • Type: Task Task
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.0-rc-3
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      The Groovy artifacts should be split in two:

      • a groovy-core.jar containing what's core to the language and the JDK (closures, default groovy methods, Swing builder, etc... with the addition of GroovyTestCase)
      • a groovy-gdk.jar containing all the library related stuff (JMX, etc)

      The groovy-core.jar should be "JarJar-ed" to embed ASM and Antlr.
      The ASM and Antlr classes embedded should be kept to a minimum (removing non-needed things like Antlr's python support and the likes)

      The sources and tests should be seperated accordingly in two different tree structures.
      No dependency from groovy-core on groovy-jdk, but groovy-jdk obviously depends on groovy-core

      Current tests should be put in some final10 folder (a better name might be appreciated) to keep all the tests as a regression testing process.
      New tests should have their own folder (package).
      And a dedicated package for TCK (language-related) tests should be created.

        Issue Links

        There are no Sub-Tasks for this issue.

          Activity

          Guillaume Laforge added a comment -

          Setting the fix to 1.8, as this related the modularity of Groovy 1.8.

          Guillaume Laforge added a comment -

          More information on modularization of Groovy 1.8:
          http://docs.codehaus.org/display/GROOVY/Groovy+1.8+modularization

          Hans Dokter is also helping us on a Gradle build for Groovy 1.8 which will enable us to move forward and make Groovy more modular.

          blackdrag blackdrag added a comment -

          I close this one as fixed, because in RC2 we had the first version of Groovy in which we have modules realized


            People

            • Assignee:
              blackdrag blackdrag
              Reporter:
              Guillaume Laforge
            • Votes:
              1 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: