Details

    • Type: Task Task
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.2
    • Fix Version/s: 0.9
    • Component/s: cli, rt
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Griffon 0.2.x depends on libraries that are a bit behind Grails 1.2M.
      In particular gant-groovy-1.6_1.5-SNAPSHOT causes trouble as
      1. it is a snapshot dependency
      2. Griffon is broken with gant-groovy1.6-1.5.0 or newer

      We should also re-arrange test dependencies, Swingx and its related jars are only required for testing but every Griffon project still references them as they are copied into $GRIFFON_HOME/lib

        Activity

        Hide
        Andres Almiray added a comment -

        Dependencies have been upgraded to

        • groovy 1.7.0
        • gant-1.9.0
        • asm 3-2
        • junit 4.8.1

        Still missing:

        • svnkit 1.3.1
        Show
        Andres Almiray added a comment - Dependencies have been upgraded to groovy 1.7.0 gant-1.9.0 asm 3-2 junit 4.8.1 Still missing: svnkit 1.3.1
        Hide
        Andres Almiray added a comment -

        Updated to same dependencies as Grails 1.3.2

        Show
        Andres Almiray added a comment - Updated to same dependencies as Grails 1.3.2

          People

          • Assignee:
            Andres Almiray
            Reporter:
            Andres Almiray
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: