Griffon
  1. Griffon
  2. GRIFFON-636

run-webstart fails on Windows when the application name has a space

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.3.0
    • Fix Version/s: 1.4.0
    • Component/s: cli
    • Labels:
      None
    • Environment:
      Windows 7 64-bit, Java 6/7
    • Number of attachments :
      0

      Description

      Execute the following to reproduce:

      griffon create-app myApp
      cd myApp
      griffon run-webstart

      It fails to start with the following error:

      InvalidArgumentException[ Invalid arguments supplied:

      {application.jnlp, App }

      ]
      at com.sun.javaws.Main.continueInSecureThread(Unknown Source)
      at com.sun.javaws.Main.access$000(Unknown Source)
      at com.sun.javaws.Main$1.run(Unknown Source)
      at java.lang.Thread.run(Thread.java:722)

      The problem seems to come from quoting the application name parameter (due to having a space) when passing into the ProcessBuilder. It works fine if you don't quote the parameters.

      From RunWebStart.groovy:

          sysProperties.each { key, value ->
              if (null == value) return
              debug("  -D$key=${quote(value)}")
              sysprops << "-J-D${key}=${quote(value)}" // take quote out and it works
          }
      

        Activity


          People

          • Assignee:
            Andres Almiray
            Reporter:
            Brett Borchardt
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: