Griffon
  1. Griffon
  2. GRIFFON-601

Error uninstalling eclipse-support plugin

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.0
    • Fix Version/s: 1.3.0
    • Component/s: cli
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Uninstalling or upgrading the eclipse-support plugin results in an error similar to the following one

      [sample]> griffon uninstall-plugin eclipse-support
      Welcome to Griffon 1.2.0 - http://griffon-framework.org/
      Licensed under Apache Standard License 2.0
      Griffon home is set to: /usr/local/griffon
      
      Base Directory: /private/tmp/sample
      Running script /usr/local/griffon/scripts/UninstallPlugin_.groovy
      Resolving dependencies...
      Dependencies resolved in 507ms.
      Environment set to development
      Resolving framework plugin dependencies ...
      Framework plugin dependencies resolved in 1140 ms.
      Resolving plugin dependencies ...
      Plugin dependencies resolved in 826 ms.
         [delete] Deleting directory /Users/aalmiray/.griffon/1.2.0/projects/sample/plugins/eclipse-support-0.6.2
      An error occured uninstalling the plugin [eclipse-support]: Cannot invoke method exists() on null object
      

      PD: there's a typo in the error message too.

        Activity

        Andres Almiray added a comment -

        The problem is caused by an NPE

           [delete] Deleting directory /Users/aalmiray/.griffon/1.3.0-SNAPSHOT/projects/sample/plugins/eclipse-support-0.7
        java.lang.NullPointerException: Cannot invoke method exists() on null object
        	at griffon.util.PluginSettings.getPluginDirForName(PluginSettings.groovy:221)
        	at griffon.util.PluginSettings$getPluginDirForName.call(Unknown Source)
        	at griffon.util.PluginSettings$_initBinding_closure1.doCall(PluginSettings.groovy:51)
        	at griffon.util.PluginSettings$_initBinding_closure1.call(PluginSettings.groovy)
        	at _Events$_run_closure2.doCall(_Events.groovy:34)
        	at org.codehaus.griffon.cli.support.GriffonBuildEventListener.triggerEvent(GriffonBuildEventListener.java:203)
        	at _GriffonSettings$_run_closure6.doCall(_GriffonSettings:56)
        	at _GriffonSettings$_run_closure6.call(_GriffonSettings)
        	at _GriffonArtifacts$_run_closure17_closure26.doCall(_GriffonArtifacts.groovy:323)
        	at _GriffonArtifacts$_run_closure17_closure26.call(_GriffonArtifacts.groovy)
        	at org.codehaus.griffon.artifacts.ArtifactInstallEngine.doUninstall(ArtifactInstallEngine.groovy:680)
        	at org.codehaus.griffon.artifacts.ArtifactInstallEngine.uninstall(ArtifactInstallEngine.groovy:637)
        	at org.codehaus.griffon.artifacts.ArtifactInstallEngine$uninstall.call(Unknown Source)
        	at _GriffonArtifacts$_run_closure6.doCall(_GriffonArtifacts.groovy:142)
        	at _GriffonArtifacts$_run_closure6.call(_GriffonArtifacts.groovy)
        	at _GriffonArtifacts$_run_closure5.doCall(_GriffonArtifacts.groovy:132)
        	at _GriffonArtifacts$_run_closure5.call(_GriffonArtifacts.groovy)
        	at _GriffonSettings$_run_closure1.doCall(_GriffonSettings:24)
        	at org.codehaus.griffon.cli.GriffonScriptRunner.executeWithGantInstance(GriffonScriptRunner.java:648)
        	at org.codehaus.griffon.cli.GriffonScriptRunner.executeWithGantInstanceNoException(GriffonScriptRunner.java:667)
        	at org.codehaus.griffon.cli.GriffonScriptRunner.callPluginOrGriffonScript(GriffonScriptRunner.java:392)
        	at org.codehaus.griffon.cli.GriffonScriptRunner.doExecuteCommand(GriffonScriptRunner.java:303)
        	at org.codehaus.griffon.cli.GriffonScriptRunner.main(GriffonScriptRunner.java:141)
        	at org.codehaus.griffon.cli.support.GriffonStarter.rootLoader(GriffonStarter.java:198)
        	at org.codehaus.griffon.cli.support.GriffonStarter.main(GriffonStarter.java:223)
        An error occured uninstalling the plugin [eclipse-support]: Cannot invoke method exists() on null object
        

          People

          • Assignee:
            Andres Almiray
            Reporter:
            Andres Almiray
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: