Griffon
  1. Griffon
  2. GRIFFON-557

Give a better error message when plugins could not be installed due to incompatible versions

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.1.0
    • Fix Version/s: 1.2.0
    • Component/s: cli
    • Labels:
      None
    • Number of attachments :
      0

      Description

      When two conflicting versions of the same plugin are found by the install sequence we get an error message like the following one

      -= MISSING =-
      + codenarc-0.7 from griffon-central
      ! miglayout-0.4 from griffon-central
         ! swing-0.9.5 from griffon-central
      + spock-0.6 from griffon-central
      + code-coverage-0.7 from griffon-central
      ! swing-1.1.0 from griffon-local
      ! glazedlists-0.9 from griffon-central
         ! swing-0.9.5 from griffon-central
      Could not resolve plugin dependencies.
      

      This error message should be improved with suggestions on how to fix the problem.

        Activity

        Show
        Andres Almiray added a comment - Fixed with https://github.com/griffon/griffon/commit/78839912212de6ca275e6139a2fe039e7cece6d6

          People

          • Assignee:
            Andres Almiray
            Reporter:
            Andres Almiray
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: