Griffon
  1. Griffon
  2. GRIFFON-555

ListPlugins throws an error when attempting a query on a remote repository in offline mode

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.1.0
    • Fix Version/s: 1.2.0
    • Component/s: cli
    • Labels:
      None
    • Environment:
    • Number of attachments :
      0

      Description

      Calling the following command

      griffon -Dgriffon.offline.mode=true list-plugins --repository=griffon-central
      

      results in the following exception being thrown

      No such property: repositoryName for class: _GriffonArtifacts
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at org.codehaus.griffon.cli.GriffonScriptRunner.executeWithGantInstance(GriffonScriptRunner.java:636)
      	at org.codehaus.griffon.cli.GriffonScriptRunner.executeWithGantInstanceNoException(GriffonScriptRunner.java:655)
      	at org.codehaus.griffon.cli.GriffonScriptRunner.callPluginOrGriffonScript(GriffonScriptRunner.java:381)
      	at org.codehaus.griffon.cli.GriffonScriptRunner.doExecuteCommand(GriffonScriptRunner.java:292)
      	at org.codehaus.griffon.cli.GriffonScriptRunner.main(GriffonScriptRunner.java:135)
      	at org.codehaus.griffon.cli.support.GriffonStarter.rootLoader(GriffonStarter.java:198)
      	at org.codehaus.griffon.cli.support.GriffonStarter.main(GriffonStarter.java:223)
      Caused by: groovy.lang.MissingPropertyException: No such property: repositoryName for class: _GriffonArtifacts
      	at _GriffonArtifacts$_run_closure2.doCall(_GriffonArtifacts.groovy:61)
      	at _GriffonArtifacts$_run_closure2.doCall(_GriffonArtifacts.groovy)
      	at _GriffonListArtifacts$_run_closure1.doCall(_GriffonListArtifacts.groovy:43)
      	at _GriffonListArtifacts$_run_closure1.call(_GriffonListArtifacts.groovy)
      	at _GriffonSettings$_run_closure1.doCall(_GriffonSettings:26)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	... 9 more
      

        Activity


          People

          • Assignee:
            Andres Almiray
            Reporter:
            Andres Almiray
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: