Griffon
  1. Griffon
  2. GRIFFON-542

Can't resolve application name when creating an application

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.1
    • Fix Version/s: 1.0.2
    • Component/s: cli
    • Labels:
      None
    • Environment:
    • Number of attachments :
      0

      Description

      Reported at the user list

      griffon create-app
      griffon: JAVA_HOME environment variable is not set
      Welcome to Griffon 1.0.1 - http://griffon-framework.org/
      Licensed under Apache Standard License 2.0
      Griffon home is set to: /home/travis/opt/griffon-1.0.1
      
      Base Directory: /home/travis/Documents
      Running script /home/travis/opt/griffon-1.0.1/scripts/CreateApp_.groovy
      Resolving dependencies...
      Dependencies resolved in 728ms.
      Environment set to development
      Resolving framework plugin dependencies ...
      Downloading: junit-4.10.jar
      Download complete.
      Downloading: hamcrest-core-1.1.jar
      Download complete.
      Framework plugin dependencies resolved in 578 ms.
          [input] Application name not specified. Please enter:
      first-griffon
          [mkdir] Created dir: /home/travis/Documents/first-griffon/griffon-app
          [mkdir] Created dir: /home/travis/Documents/first-griffon/griffon-app/conf
          [mkdir] Created dir: /home/travis/Documents/first-griffon/griffon-app/conf/keys
          [mkdir] Created dir: /home/travis/Documents/first-griffon/griffon-app/conf/webstart
          [mkdir] Created dir: /home/travis/Documents/first-griffon/griffon-app/conf/dist
          [mkdir] Created dir: /home/travis/Documents/first-griffon/griffon-app/conf/dist/applet
          [mkdir] Created dir: /home/travis/Documents/first-griffon/griffon-app/conf/dist/jar
          [mkdir] Created dir: /home/travis/Documents/first-griffon/griffon-app/conf/dist/shared
          [mkdir] Created dir: /home/travis/Documents/first-griffon/griffon-app/conf/dist/webstart
          [mkdir] Created dir: /home/travis/Documents/first-griffon/griffon-app/conf/dist/zip
          [mkdir] Created dir: /home/travis/Documents/first-griffon/griffon-app/conf/metainf
          [mkdir] Created dir: /home/travis/Documents/first-griffon/griffon-app/controllers
          [mkdir] Created dir: /home/travis/Documents/first-griffon/griffon-app/i18n
          [mkdir] Created dir: /home/travis/Documents/first-griffon/griffon-app/lifecycle
          [mkdir] Created dir: /home/travis/Documents/first-griffon/griffon-app/models
          [mkdir] Created dir: /home/travis/Documents/first-griffon/griffon-app/resources
          [mkdir] Created dir: /home/travis/Documents/first-griffon/griffon-app/views
          [mkdir] Created dir: /home/travis/Documents/first-griffon/lib
          [mkdir] Created dir: /home/travis/Documents/first-griffon/scripts
          [mkdir] Created dir: /home/travis/Documents/first-griffon/src
          [mkdir] Created dir: /home/travis/Documents/first-griffon/src/main
          [mkdir] Created dir: /home/travis/Documents/first-griffon/test
          [mkdir] Created dir: /home/travis/Documents/first-griffon/test/integration
          [mkdir] Created dir: /home/travis/Documents/first-griffon/test/unit
      [propertyfile] Creating new property file: /home/travis/Documents/first-griffon/application.properties
           [copy] Copying 1 resource to /home/travis/Documents/first-griffon
          [unjar] Expanding: /home/travis/Documents/first-griffon/griffon-shared-files.jar into /home/travis/Documents/first-griffon
         [delete] Deleting: /home/travis/Documents/first-griffon/griffon-shared-files.jar
           [copy] Copying 1 resource to /home/travis/Documents/first-griffon
          [unjar] Expanding: /home/travis/Documents/first-griffon/griffon-app-files.jar into /home/travis/Documents/first-griffon
         [delete] Deleting: /home/travis/Documents/first-griffon/griffon-app-files.jar
          [unzip] Expanding: /home/travis/Documents/first-griffon/griffon-wrapper-files.zip into /home/travis/Documents/first-griffon
         [delete] Deleting: /home/travis/Documents/first-griffon/griffon-wrapper-files.zip
      java.lang.NullPointerException: Cannot invoke method lastIndexOf() on null object
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at org.codehaus.griffon.cli.GriffonScriptRunner.executeWithGantInstance(GriffonScriptRunner.java:647)
      	at org.codehaus.griffon.cli.GriffonScriptRunner.executeWithGantInstanceNoException(GriffonScriptRunner.java:666)
      	at org.codehaus.griffon.cli.GriffonScriptRunner.callPluginOrGriffonScript(GriffonScriptRunner.java:392)
      	at org.codehaus.griffon.cli.GriffonScriptRunner.doExecuteCommand(GriffonScriptRunner.java:303)
      	at org.codehaus.griffon.cli.GriffonScriptRunner.main(GriffonScriptRunner.java:146)
      	at org.codehaus.griffon.cli.support.GriffonStarter.rootLoader(GriffonStarter.java:198)
      	at org.codehaus.griffon.cli.support.GriffonStarter.main(GriffonStarter.java:223)
      Caused by: java.lang.NullPointerException: Cannot invoke method lastIndexOf() on null object
      	at _GriffonCreateArtifacts$_run_closure9.doCall(_GriffonCreateArtifacts.groovy:233)
      	at _GriffonCreateProject$_run_closure2.doCall(_GriffonCreateProject.groovy:70)
      	at _GriffonCreateProject$_run_closure2.doCall(_GriffonCreateProject.groovy)
      	at script13433454977491286036704$_run_closure1.doCall(script13433454977491286036704.groovy:26)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at _GriffonCreateProject$_run_closure1.doCall(_GriffonCreateProject.groovy:41)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	... 9 more
      

        Activity


          People

          • Assignee:
            Andres Almiray
            Reporter:
            Andres Almiray
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: