Griffon
  1. Griffon
  2. GRIFFON-537

Exception while running test-app on plugin with add-on

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.1
    • Fix Version/s: 1.0.2
    • Component/s: cli
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Repro steps:

      1. griffon create-plugin foo
      2. cd foo
      3. griffon create-addon foo
      4. griffon test-app

      This results in the output:

      $ gri test-app
      Welcome to Griffon 1.0.1 - http://griffon-framework.org/
      Licensed under Apache Standard License 2.0
      Griffon home is set to: /Users/dean/devel/jvm/groovy/griffon
      
      Base Directory: /Users/dean/devel/jvm/groovy/projects/griffon/plugins/foo
      Running script /Users/dean/devel/jvm/groovy/griffon/scripts/TestApp.groovy
      Resolving dependencies...
      Dependencies resolved in 250ms.
      Environment set to test
      Resolving framework plugin dependencies ...
      Framework plugin dependencies resolved in 239 ms.
      Resolving plugin dependencies ...
      Plugin dependencies resolved in 218 ms.
          [mkdir] Created dir: /Users/dean/.griffon/1.0.1/projects/foo/classes/cli
          [mkdir] Created dir: /Users/dean/.griffon/1.0.1/projects/foo/classes/main
          [mkdir] Created dir: /Users/dean/.griffon/1.0.1/projects/foo/classes/test
          [mkdir] Created dir: /Users/dean/.griffon/1.0.1/projects/foo/test-classes
          [mkdir] Created dir: /Users/dean/.griffon/1.0.1/projects/foo/test-resources
          [mkdir] Created dir: /Users/dean/.griffon/1.0.1/projects/foo/resources
       [griffonc] Compiling 1 source file to /Users/dean/.griffon/1.0.1/projects/foo/classes/main
           [copy] Copied 1 empty directory to 1 empty directory under /Users/dean/.griffon/1.0.1/projects/foo/resources
          [mkdir] Created dir: /Users/dean/devel/jvm/groovy/projects/griffon/plugins/foo/target/test-reports
          [mkdir] Created dir: /Users/dean/devel/jvm/groovy/projects/griffon/plugins/foo/target/test-reports/html
          [mkdir] Created dir: /Users/dean/devel/jvm/groovy/projects/griffon/plugins/foo/target/test-reports/plain
      
      Starting unit test phase ...
          [mkdir] Created dir: /Users/dean/.griffon/1.0.1/projects/foo/test-classes/unit
      
      Starting integration test phase ...
           [copy] Copying 1 file to /Users/dean/.griffon/1.0.1/projects/foo/test-classes/integration
          [mkdir] Created dir: /Users/dean/devel/jvm/groovy/projects/griffon/plugins/foo/griffon-app/conf/keys
          [mkdir] Created dir: /Users/dean/devel/jvm/groovy/projects/griffon/plugins/foo/griffon-app/conf/webstart
          [mkdir] Created dir: /Users/dean/devel/jvm/groovy/projects/griffon/plugins/foo/griffon-app/conf/dist
          [mkdir] Created dir: /Users/dean/devel/jvm/groovy/projects/griffon/plugins/foo/griffon-app/conf/dist/applet
          [mkdir] Created dir: /Users/dean/devel/jvm/groovy/projects/griffon/plugins/foo/griffon-app/conf/dist/jar
          [mkdir] Created dir: /Users/dean/devel/jvm/groovy/projects/griffon/plugins/foo/griffon-app/conf/dist/shared
          [mkdir] Created dir: /Users/dean/devel/jvm/groovy/projects/griffon/plugins/foo/griffon-app/conf/dist/webstart
          [mkdir] Created dir: /Users/dean/devel/jvm/groovy/projects/griffon/plugins/foo/griffon-app/conf/dist/zip
      [junitreport] Processing /Users/dean/devel/jvm/groovy/projects/griffon/plugins/foo/target/test-reports/TESTS-TestSuites.xml to /var/folders/x9/gf9vr4ss2j1_26knwqdnprzm0000gn/T/null910511418
      [junitreport] Loading stylesheet jar:file:/Users/dean/devel/jvm/groovy/griffon/lib/ant-junit-1.8.2.jar!/org/apache/tools/ant/taskdefs/optional/junit/xsl/junit-frames.xsl
      [junitreport] Transform time: 312ms
      [junitreport] Deleting: /var/folders/x9/gf9vr4ss2j1_26knwqdnprzm0000gn/T/null910511418
      
      Tests PASSED - view reports in /Users/dean/devel/jvm/groovy/projects/griffon/plugins/foo/target/test-reports
      groovy.lang.MissingMethodException: No signature of method: org.apache.tools.ant.Project.replaceProperties() is applicable for argument types: (groovy.util.ConfigObject) values: [[:]]
      Possible solutions: replaceProperties(java.lang.String)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at org.codehaus.griffon.cli.GriffonScriptRunner.executeWithGantInstance(GriffonScriptRunner.java:647)
      	at org.codehaus.griffon.cli.GriffonScriptRunner.executeWithGantInstanceNoException(GriffonScriptRunner.java:666)
      	at org.codehaus.griffon.cli.GriffonScriptRunner.callPluginOrGriffonScript(GriffonScriptRunner.java:392)
      	at org.codehaus.griffon.cli.GriffonScriptRunner.doExecuteCommand(GriffonScriptRunner.java:303)
      	at org.codehaus.griffon.cli.GriffonScriptRunner.main(GriffonScriptRunner.java:146)
      	at org.codehaus.griffon.cli.support.GriffonStarter.rootLoader(GriffonStarter.java:198)
      	at org.codehaus.griffon.cli.support.GriffonStarter.main(GriffonStarter.java:223)
      Caused by: groovy.lang.MissingMethodException: No signature of method: org.apache.tools.ant.Project.replaceProperties() is applicable for argument types: (groovy.util.ConfigObject) values: [[:]]
      Possible solutions: replaceProperties(java.lang.String)
      	at _GriffonPackage$_run_closure2.doCall(_GriffonPackage.groovy:71)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at Package$_run_closure3.doCall(Package.groovy:93)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at _GriffonBootstrap$_run_closure2.doCall(_GriffonBootstrap.groovy:44)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at _GriffonBootstrap$_run_closure1.doCall(_GriffonBootstrap.groovy:39)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at _GriffonTest$_run_closure8.doCall(_GriffonTest.groovy:335)
      	at _GriffonTest$_run_closure8.doCall(_GriffonTest.groovy)
      	at _GriffonTest$_run_closure2_closure25.doCall(_GriffonTest.groovy:212)
      	at _GriffonTest$_run_closure2.doCall(_GriffonTest.groovy:202)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at _GriffonSettings$_run_closure1.doCall(_GriffonSettings:80)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	... 9 more
      

        Activity


          People

          • Assignee:
            Andres Almiray
            Reporter:
            Dean Iverson
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: