Griffon
  1. Griffon
  2. GRIFFON-516

NPE when using RunApp from the command line

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.0
    • Fix Version/s: 1.0.1
    • Component/s: cli
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Exception is below. This was on a project upgraded from 0.9.5.

      java.lang.NullPointerException
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at org.codehaus.griffon.cli.GriffonScriptRunner.executeWithGantInstance(GriffonScriptRunner.java:647)
      	at org.codehaus.griffon.cli.GriffonScriptRunner.executeWithGantInstanceNoException(GriffonScriptRunner.java:666)
      	at org.codehaus.griffon.cli.GriffonScriptRunner.callPluginOrGriffonScript(GriffonScriptRunner.java:392)
      	at org.codehaus.griffon.cli.GriffonScriptRunner.doExecuteCommand(GriffonScriptRunner.java:303)
      	at org.codehaus.griffon.cli.GriffonScriptRunner.main(GriffonScriptRunner.java:146)
      	at org.codehaus.griffon.cli.support.GriffonStarter.rootLoader(GriffonStarter.java:198)
      	at org.codehaus.griffon.cli.support.GriffonStarter.main(GriffonStarter.java:223)
      Caused by: java.lang.NullPointerException
      	at griffon.util.GriffonNameUtils.quote(GriffonNameUtils.java:375)
      	at griffon.util.GriffonNameUtils$quote.callStatic(Unknown Source)
      	at _GriffonSettings$_run_closure2_closure5.doCall(_GriffonSettings:119)
      	at _GriffonSettings$_run_closure2.doCall(_GriffonSettings:117)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at _GriffonSettings$_run_closure1.doCall(_GriffonSettings:36)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	... 9 more
      

        Activity


          People

          • Assignee:
            Andres Almiray
            Reporter:
            Dean Iverson
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: