Griffon
  1. Griffon
  2. GRIFFON-515

[griffonsh] RunApp fails to execute with an exception

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.0
    • Fix Version/s: 1.0.1
    • Component/s: cli
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Executing run-app inside griffonsh leads to an exception

      No such property: sysProperties for class: RunApp
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at org.codehaus.griffon.cli.GriffonScriptRunner.executeWithGantInstance(GriffonScriptRunner.java:647)
      	at org.codehaus.griffon.cli.shell.GantAwareAction.doExecute(GantAwareAction.java:93)
      	at org.codehaus.griffon.cli.shell.AbstractGriffonShellCommand.execute(AbstractGriffonShellCommand.java:55)
      	at org.codehaus.griffon.cli.shell.support.GriffonCommandFactory.execute(GriffonCommandFactory.java:65)
      	at org.apache.felix.gogo.runtime.Closure.executeCmd(Closure.java:477)
      	at org.apache.felix.gogo.runtime.Closure.executeStatement(Closure.java:403)
      	at org.apache.felix.gogo.runtime.Pipe.run(Pipe.java:108)
      	at org.apache.felix.gogo.runtime.Closure.execute(Closure.java:183)
      	at org.apache.felix.gogo.runtime.Closure.execute(Closure.java:120)
      	at org.apache.felix.gogo.runtime.CommandSessionImpl.execute(CommandSessionImpl.java:89)
      	at org.apache.karaf.shell.console.jline.Console.run(Console.java:221)
      	at org.codehaus.griffon.cli.shell.KarafMain.run(KarafMain.java:187)
      	at org.codehaus.griffon.cli.shell.KarafMain.run(KarafMain.java:81)
      	at org.codehaus.griffon.cli.shell.GriffonShell.main(GriffonShell.java:60)
      	at org.codehaus.griffon.cli.support.GriffonStarter.rootLoader(GriffonStarter.java:198)
      	at org.codehaus.griffon.cli.support.GriffonStarter.main(GriffonStarter.java:223)
      Caused by: groovy.lang.MissingPropertyException: No such property: sysProperties for class: RunApp
      	at RunApp$_run_closure2.doCall(RunApp.groovy:114)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at RunApp$_run_closure1.doCall(RunApp.groovy:36)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	... 18 more
      

        Activity


          People

          • Assignee:
            Andres Almiray
            Reporter:
            Andres Almiray
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: