Griffon
  1. Griffon
  2. GRIFFON-475

Can't launch and application that makes use of the JOGL plugin

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.9.5-rc2
    • Fix Version/s: 0.9.5
    • Component/s: cli
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Invoking run-app on an application that has the JOGl plugin installed results in an exception

      No such property: absolutePath for class: org.springframework.core.io.FileSystemResource
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at org.codehaus.griffon.cli.GriffonScriptRunner.executeWithGantInstance(GriffonScriptRunner.java:635)
      	at org.codehaus.griffon.cli.GriffonScriptRunner.executeWithGantInstanceNoException(GriffonScriptRunner.java:654)
      	at org.codehaus.griffon.cli.GriffonScriptRunner.callPluginOrGriffonScript(GriffonScriptRunner.java:384)
      	at org.codehaus.griffon.cli.GriffonScriptRunner.doExecuteCommand(GriffonScriptRunner.java:297)
      	at org.codehaus.griffon.cli.GriffonScriptRunner.main(GriffonScriptRunner.java:142)
      	at org.codehaus.griffon.cli.support.GriffonStarter.rootLoader(GriffonStarter.java:198)
      	at org.codehaus.griffon.cli.support.GriffonStarter.main(GriffonStarter.java:223)
      Caused by: groovy.lang.MissingPropertyException: No such property: absolutePath for class: org.springframework.core.io.FileSystemResource
      	at _GriffonSettings$_run_closure2_closure10_closure13.doCall(_GriffonSettings:78)
      	at _GriffonSettings$_run_closure2_closure10.doCall(_GriffonSettings:76)
      	at _GriffonSettings$_run_closure2.doCall(_GriffonSettings:88)
      	at _GriffonSettings$_run_closure2.doCall(_GriffonSettings)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at _GriffonSettings$_run_closure3.doCall(_GriffonSettings:112)
      	at _GriffonSettings$_run_closure3.doCall(_GriffonSettings)
      	at _GriffonSettings.setClasspath(_GriffonSettings:201)
      	at _GriffonSettings$_run_closure1.doCall(_GriffonSettings:38)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at _GriffonCompile$_run_closure3.doCall(_GriffonCompile.groovy:86)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at _GriffonPackage$_run_closure1.doCall(_GriffonPackage.groovy:47)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at Package$_run_closure3.doCall(Package.groovy:88)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at RunApp$_run_closure2.doCall(RunApp.groovy:39)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at RunApp$_run_closure1.doCall(RunApp.groovy:35)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	at java_util_concurrent_Callable$call.call(Unknown Source)
      	... 9 more
      

        Activity

        Andres Almiray made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 0.9.5 [ 18365 ]
        Resolution Fixed [ 1 ]
        Andres Almiray made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            Andres Almiray
            Reporter:
            Andres Almiray
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: