Griffon
  1. Griffon
  2. GRIFFON-425

calling app.shutdown() from Initialize.groovy causes a NPE

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 0.9.4
    • Fix Version/s: 0.9.4
    • Component/s: rt
    • Labels:
      None
    • Environment:
      Windows 7, new clean application
    • Number of attachments :
      0

      Description

      2011-10-20 12:17:33,238 [pool-2-thread-1] INFO griffon.swing.SwingApplication - Shutdown is in process
      2011-10-20 12:17:33,253 [pool-2-thread-1] ERROR griffon.util.GriffonExceptionHandler - Uncaught Exception
      java.lang.NullPointerException
      at org.codehaus.griffon.runtime.core.AbstractGriffonApplication.shutdown(AbstractGriffonApplication.java:280)
      at griffon.swing.AbstractSwingGriffonApplication.shutdown(AbstractSwingGriffonApplication.java:87)
      at griffon.core.GriffonApplication$shutdown.call(Unknown Source)
      at Initialize$_run_closure1.doCall(Initialize.groovy:21)
      at Initialize$_run_closure1.doCall(Initialize.groovy)
      at org.codehaus.griffon.runtime.util.AbstractUIThreadHandler$1.run(AbstractUIThreadHandler.java:41)

        Activity

        Edo added a comment -

        This is still happening with today's official 0.9.4 release

        java.lang.RuntimeException: java.lang.NullPointerException
        at griffon.swing.SwingUIThreadHandler.executeSync(SwingUIThreadHandler.java:46)
        at griffon.core.UIThreadManager.executeSync(UIThreadManager.java:149)
        at griffon.core.UIThreadManager$executeSync.call(Unknown Source)
        at org.codehaus.griffon.runtime.util.GriffonApplicationHelper.runScript(GriffonApplicationHelper.groovy:279)
        at org.codehaus.griffon.runtime.util.GriffonApplicationHelper.runLifecycleHandler(GriffonApplicationHelper.groovy:269)
        at org.codehaus.griffon.runtime.util.GriffonApplicationHelper$runLifecycleHandler.callStatic(Unknown Source)
        at org.codehaus.griffon.runtime.util.GriffonApplicationHelper.prepare(GriffonApplicationHelper.groovy:108)
        at org.codehaus.griffon.runtime.core.AbstractGriffonApplication.initialize(AbstractGriffonApplication.java:206)
        at griffon.swing.AbstractSwingGriffonApplication.bootstrap(AbstractSwingGriffonApplication.java:74)
        at griffon.swing.AbstractSwingGriffonApplication.run(AbstractSwingGriffonApplication.java:131)
        at griffon.swing.SwingApplication.main(SwingApplication.java:36)
        Caused by: java.lang.NullPointerException
        at org.codehaus.griffon.runtime.core.AbstractGriffonApplication.shutdown(AbstractGriffonApplication.java:280)
        at griffon.swing.AbstractSwingGriffonApplication.shutdown(AbstractSwingGriffonApplication.java:87)
        at griffon.core.GriffonApplication$shutdown.call(Unknown Source)
        at Initialize.run(Initialize.groovy:20)

        Andres Almiray added a comment -

        If you tried 0.9.4 before the official release then please delete your Ivy cache and retry.
        Your Ivy cache is located at $USER_HOME/.ivy2/cache/org.codehaus.griffon

        Edo added a comment - - edited

        Tried both clearing ~/.ivy2 and ~/.griffon, and running clean but it's still NPEing, I will try again later tonight at home.

        Edo added a comment -

        It seems the tgz linked at http://griffon.codehaus.org/Download is a snapshot from a few days ago, after downloading the zip package I noticed the last modified date are different for several files between both packages.

        After replacing griffon with the zip packed version and clearing both org.codehaus.griffon from ~/.ivy2 and ~/.griffon (not sure if the last one was needed) the NPE is gone.

        Andres Almiray added a comment -

        Hmm interesting. I'll replace the .tgz artifact right away.
        Thanks!


          People

          • Assignee:
            Andres Almiray
            Reporter:
            Edo
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: