Griffon
  1. Griffon
  2. GRIFFON-216

Can't run an application on Linux

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.9
    • Fix Version/s: 0.9
    • Component/s: cli
    • Labels:
      None
    • Environment:
      JDK 1.6.0.21, Grifofn 0.9, Ubuntu Lucid
    • Number of attachments :
      0

      Description

      The following exception occurs when attempting to run an application with run-app, however run-applet and run-webstart work fine.

      $ griffon a
      Welcome to Griffon 0.9 - http://griffon.codehaus.org/
      Licensed under Apache Standard License 2.0
      Griffon home is set to: /usr/local/griffon
      
      Base Directory: /tmp/a
      Resolving dependencies...
      Dependencies resolved in 567ms.
      Running script /usr/local/griffon/scripts/App.groovy
      Environment set to development
          [mkdir] Created dir: /home/aalmiray/.griffon/0.9/projects/a/classes
          [mkdir] Created dir: /home/aalmiray/.griffon/0.9/projects/a/plugin-classes
          [mkdir] Created dir: /home/aalmiray/.griffon/0.9/projects/a/test-classes/shared
          [mkdir] Created dir: /home/aalmiray/.griffon/0.9/projects/a/test-resources
        [groovyc] Compiling 8 source files to /home/aalmiray/.griffon/0.9/projects/a/classes
        [groovyc] Compiling 4 source files to /home/aalmiray/.griffon/0.9/projects/a/classes
          [mkdir] Created dir: /home/aalmiray/.griffon/0.9/projects/a/resources/griffon-app/i18n
          [mkdir] Created dir: /home/aalmiray/.griffon/0.9/projects/a/resources/griffon-app/resources
           [copy] Copying 1 file to /home/aalmiray/.griffon/0.9/projects/a/resources/griffon-app/i18n
           [copy] Copying 8 files to /home/aalmiray/.griffon/0.9/projects/a/resources/griffon-app/resources
           [copy] Copying 1 file to /home/aalmiray/.griffon/0.9/projects/a/classes
           [copy] Copying 11 files to /home/aalmiray/.griffon/0.9/projects/a/resources
           [copy] Copied 8 empty directories to 7 empty directories under /home/aalmiray/.griffon/0.9/projects/a/resources
           [copy] Copying 1 file to /tmp/a/staging
           [copy] Copying 1 file to /tmp/a/staging
      java.lang.reflect.InvocationTargetException
      	at griffon.swing.SwingUIThreadHandler.executeSync(SwingUIThreadHandler.groovy:39)
      	at griffon.util.UIThreadHandler$executeSync.call(Unknown Source)
      	at griffon.util.UIThreadHelper.executeSync(UIThreadHelper.groovy:93)
      	at griffon.util.UIThreadHelper$executeSync$0.call(Unknown Source)
      	at griffon.util.internal.GriffonApplicationHelper$_buildMVCGroup_closure10.doCall(GriffonApplicationHelper.groovy:285)
      	at griffon.util.internal.GriffonApplicationHelper.buildMVCGroup(GriffonApplicationHelper.groovy:281)
      	at griffon.util.internal.GriffonApplicationHelper$buildMVCGroup.callStatic(Unknown Source)
      	at griffon.util.internal.GriffonApplicationHelper.createMVCGroup(GriffonApplicationHelper.groovy:191)
      	at griffon.util.internal.GriffonApplicationHelper$createMVCGroup$0.callStatic(Unknown Source)
      	at griffon.util.internal.GriffonApplicationHelper.createMVCGroup(GriffonApplicationHelper.groovy:171)
      	at griffon.util.internal.GriffonApplicationHelper$createMVCGroup.call(Unknown Source)
      	at griffon.core.BaseGriffonApplication$_startup_closure2.doCall(BaseGriffonApplication.groovy:178)
      	at griffon.core.BaseGriffonApplication.startup(BaseGriffonApplication.groovy:177)
      	at griffon.core.GriffonApplication$startup.call(Unknown Source)
      	at griffon.swing.SwingApplication.startup(SwingApplication.groovy)
      	at griffon.core.GriffonApplication$startup.callCurrent(Unknown Source)
      	at griffon.swing.SwingApplication.realize(SwingApplication.groovy:61)
      	at griffon.application.StandaloneGriffonApplication$realize.call(Unknown Source)
      	at griffon.swing.SwingApplication.main(SwingApplication.groovy:107)
      Caused by: java.lang.RuntimeException: Failed to create component for 'application' reason: java.awt.HeadlessException: 
      No X11 DISPLAY variable was set, but this program performed an operation which requires it.
      	at griffon.util.internal.CompositeBuilderHelper$_handleLocalBuilder_closure3_closure7.doCall(CompositeBuilderHelper.groovy:118)
      	at griffon.builder.UberInterceptorMetaClass.invokeMethod(UberBuilder.groovy:376)
      	at a.AView.run(AView.groovy:11)
      	at griffon.builder.UberInterceptorMetaClass.invokeMethod(UberBuilder.groovy:376)
      	at griffon.builder.UberBuilder.build(UberBuilder.groovy:143)
      	at griffon.builder.UberBuilder$build.call(Unknown Source)
      	at griffon.util.internal.GriffonApplicationHelper$_buildMVCGroup_closure10_closure16.doCall(GriffonApplicationHelper.groovy:285)
      	at griffon.util.internal.GriffonApplicationHelper$_buildMVCGroup_closure10_closure16.doCall(GriffonApplicationHelper.groovy)
      Caused by: java.awt.HeadlessException: 
      No X11 DISPLAY variable was set, but this program performed an operation which requires it.
      	at griffon.swing.SwingUtils.createApplicationFrame(SwingUtils.groovy:102)
      	at griffon.swing.SwingUtils$createApplicationFrame.call(Unknown Source)
      	at griffon.swing.SwingApplication.createApplicationContainer(SwingApplication.groovy:83)
      	at griffon.core.GriffonApplication$createApplicationContainer.call(Unknown Source)
      	at griffon.app.ApplicationFactory.newInstance(ApplicationFactory.groovy:54)
      	... 8 more
      

        Activity

        Andres Almiray added a comment -

        Looks like this problem is specific to RunApp.groovy as an application packaged in either zip or jar mode runs perfectly well.

        Alexander Jipa added a comment -

        Got a similar error while trying to launch an application on Windows 7 (x86). Pointed out that the problem is with the fileChooser component. Sun support has info about this bug, and suggested workaround (http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=4879395) is to set a VM parameter: -Dswing.disableFileChooserSpeedFix=true

        java.lang.reflect.InvocationTargetException
        at griffon.swing.SwingUIThreadHandler.executeSync(SwingUIThreadHandler.groovy:39)
        at griffon.util.UIThreadHandler$executeSync$0.call(Unknown Source)
        at griffon.util.UIThreadHelper.executeSync(UIThreadHelper.groovy:93)
        at griffon.util.UIThreadHelper$executeSync$0.call(Unknown Source)
        at griffon.util.internal.GriffonApplicationHelper$_buildMVCGroup_closure10.doCall(GriffonApplicationHelper.groovy:285)
        at griffon.util.internal.GriffonApplicationHelper.buildMVCGroup(GriffonApplicationHelper.groovy:281)
        at griffon.util.internal.GriffonApplicationHelper$buildMVCGroup.callStatic(Unknown Source)
        at griffon.util.internal.GriffonApplicationHelper.createMVCGroup(GriffonApplicationHelper.groovy:191)
        at griffon.util.internal.GriffonApplicationHelper$createMVCGroup$0.callStatic(Unknown Source)
        at griffon.util.internal.GriffonApplicationHelper.createMVCGroup(GriffonApplicationHelper.groovy:171)
        at griffon.util.internal.GriffonApplicationHelper$createMVCGroup.call(Unknown Source)
        at griffon.core.BaseGriffonApplication$_startup_closure2.doCall(BaseGriffonApplication.groovy:178)
        at griffon.core.BaseGriffonApplication.startup(BaseGriffonApplication.groovy:177)
        at griffon.core.GriffonApplication$startup.call(Unknown Source)
        at griffon.swing.SwingApplication.startup(SwingApplication.groovy)
        at griffon.core.GriffonApplication$startup.callCurrent(Unknown Source)
        at griffon.swing.SwingApplication.realize(SwingApplication.groovy:61)
        at griffon.application.StandaloneGriffonApplication$realize.call(Unknown Source)
        at griffon.swing.SwingApplication.main(SwingApplication.groovy:107)
        Caused by: org.codehaus.groovy.runtime.InvokerInvocationException: java.lang.InternalError: Could not bind shell folder to interface
        Caused by: java.lang.InternalError: Could not bind shell folder to interface


          People

          • Assignee:
            Andres Almiray
            Reporter:
            Andres Almiray
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: