Griffon
  1. Griffon
  2. GRIFFON-215

Sample apps do not run with 0.9-SNAPSHOT

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 0.9
    • Fix Version/s: 0.9
    • Component/s: cli
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Execution of any of the 5 sample apps fails with the following exception

      Error executing script A: groovy.lang.MissingMethodException: No signature of method: org.apache.tools.ant.Project.replaceProperties() is applicable for argument types: (groovy.util.ConfigObject) values: [[:]]
      Possible solutions: replaceProperties(java.lang.String)
      groovy.lang.MissingMethodException: No signature of method: org.apache.tools.ant.Project.replaceProperties() is applicable for argument types: (groovy.util.ConfigObject) values: [[:]]
      Possible solutions: replaceProperties(java.lang.String)
      	at gant.Gant$_dispatch_closure5.doCall(Gant.groovy:391)
      	at gant.Gant$_dispatch_closure7.doCall(Gant.groovy:415)
      	at gant.Gant$_dispatch_closure7.doCall(Gant.groovy)
      	at gant.Gant.withBuildListeners(Gant.groovy:427)
      	at gant.Gant.this$2$withBuildListeners(Gant.groovy)
      	at gant.Gant$this$2$withBuildListeners.callCurrent(Unknown Source)
      	at gant.Gant.dispatch(Gant.groovy:415)
      	at gant.Gant.this$2$dispatch(Gant.groovy)
      	at gant.Gant.invokeMethod(Gant.groovy)
      	at gant.Gant.executeTargets(Gant.groovy:590)
      	at gant.Gant.executeTargets(Gant.groovy:589)
      Caused by: groovy.lang.MissingMethodException: No signature of method: org.apache.tools.ant.Project.replaceProperties() is applicable for argument types: (groovy.util.ConfigObject) values: [[:]]
      Possible solutions: replaceProperties(java.lang.String)
      	at _GriffonPackage_groovy$_run_closure2.doCall(_GriffonPackage_groovy:85)
      	at Package_groovy$_run_closure2.doCall(Package_groovy:71)
      	at RunApp_groovy$_run_closure2.doCall(RunApp_groovy:39)
      	at App$_run_closure1.doCall(App.groovy:29)
      	at gant.Gant$_dispatch_closure5.doCall(Gant.groovy:381)
      	... 10 more
      Error executing script A: groovy.lang.MissingMethodException: No signature of method: org.apache.tools.ant.Project.replaceProperties() is applicable for argument types: (groovy.util.ConfigObject) values: [[:]]
      Possible solutions: replaceProperties(java.lang.String)
      

        Activity

        Andres Almiray added a comment -

        The file griffon-app/conf/BuildConfig.groovy was missing in each application.


          People

          • Assignee:
            Andres Almiray
            Reporter:
            Andres Almiray
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: