Griffon
  1. Griffon
  2. GRIFFON-106

Packaging error on WSClient plugin (groovyws-standalone-0.5.0.jar)

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.1
    • Fix Version/s: 0.9.5-rc1
    • Component/s: plugins
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Hi folks,

      i've played around with the wsclient plugin. It works fine till I tried
      "griffon run-applet". That gave me the following error:
      ----------snip-------------------
      [signjar] jarsigner: unable to sign jar: java.util.zip.ZipException:
      duplicate entry: META-INF/LICENSE
      ----------snip--------------------

      Looking at groovyws-standalone-0.5.0.jar in the staging directory indeed
      gives multiple entries for LICENSE, DEPENDENCIES, LICENSE.txt, NOTICE
      and NOTICE.txt in the META-INF directory. The files have different dates
      and sizes.
      Look like a packaging error.

      Cheers,
      Jens

        Activity

        Andres Almiray added a comment -

        Grepping for LICENSE on wsclient-standalone-0.5.0.jar yields

        $ unzip -l staging/groovyws-standalone-0.5.0.jar| grep LICENSE
            11358  02-05-09 15:03   META-INF/LICENSE
            11358  11-19-07 00:16   META-INF/LICENSE
            11359  04-17-08 09:16   LICENSE.txt
            11358  02-26-09 12:55   META-INF/LICENSE
             1060  01-26-05 17:15   META-INF/LICENSE.txt
            11359  02-01-08 10:37   META-INF/LICENSE
            11359  02-01-08 10:26   META-INF/LICENSE
            11359  12-18-07 17:57   META-INF/LICENSE.txt
            11358  08-28-08 21:38   META-INF/LICENSE
              437  12-29-06 10:38   LICENSE
            11359  02-01-08 11:47   META-INF/LICENSE
            11358  05-23-08 14:09   META-INF/LICENSE
             2051  07-11-08 13:40   org/bouncycastle/LICENSE.class
            11358  06-23-08 15:51   META-INF/LICENSE.txt
             1581  02-05-06 16:49   META-INF/LICENSE.txt
             2564  11-14-07 02:16   META-INF/LICENSE.txt
            14422  03-12-08 15:52   META-INF/LICENSE
        

        That's plenty of duplicates. A tweaked groovyws jar may be created as a workaround but I rather see this issue solved by the groovyws module. I'll contact the author.

        Guillaume ALLEON added a comment -

        Would you share a sample app that would reproduce the problem ?

        Andres Almiray added a comment -

        Hi Guillaume,

        You'll need to have Griffon 0.2 installed on your machine (http://griffon.codehaus.org/download). Installation is pretty much the same as with Groovy & Grails:
        1. unzip
        2. configure GRIFFON_HOME and PATH
        You can also install Griffon via the universla installer: http://dist.codehaus.org/griffon/griffon/0.2.x/griffon-installer-0.2.jar

        Once you have it ready, follow these steps to reproduce the problem:
        1. griffon create-app sample
        2. cd sample
        3. griffon install-plugin wsclient
        4. griffon run-applet

        Guillaume ALLEON added a comment -

        Hi Andres

        Will configure IntelliJ 9.0 Beta and will provide a new version of the plugin.
        I will provide something similar to the REST plugin and will therefore remove the server part which is included in the standalone jar.

        Do you know anyone packaging a plugin using gradle ? I could add this in my groovyws distro.

        Guillaume ALLEON added a comment -

        When I do the steps above, I got the following. Any idea what's wrong ?

        oggy:griffon-wsclient alleon$ griffon run-applet
        Welcome to Griffon 0.2 - http://griffon.codehaus.org/
        Licensed under Apache Standard License 2.0
        Griffon home is set to: /Applications/griffon-0.2

        Base Directory: /Users/alleon/groovy/griffon-wsclient
        Running script /Applications/griffon-0.2/scripts/RunApplet.groovy
        Environment set to development
        Warning, target causing name overwriting of name default
        Found application events script
        Loading with installed plug-ins: [wsclient] ...
        Enter the keystore password:griffon
        Enter the key password [blank if same as keystore] :griffon
        Error executing script RunApplet: No signature of method: org.apache.tools.ant.Project.replaceProperties() is applicable for argument types: (groovy.util.ConfigObject) values: [[:]]
        gant.TargetExecutionException: No signature of method: org.apache.tools.ant.Project.replaceProperties() is applicable for argument types: (groovy.util.ConfigObject) values: [[:]]
        at gant.Gant$_dispatch_closure4.doCall(Gant.groovy:313)
        at gant.Gant.dispatch(Gant.groovy:316)
        at gant.Gant.this$2$dispatch(Gant.groovy)
        at gant.Gant.invokeMethod(Gant.groovy)
        at gant.Gant.processTargets(Gant.groovy:446)
        at gant.Gant.processTargets(Gant.groovy:430)
        Caused by: groovy.lang.MissingMethodException: No signature of method: org.apache.tools.ant.Project.replaceProperties() is applicable for argument types: (groovy.util.ConfigObject) values: [[:]]
        at _GriffonPackage_groovy$_run_closure3.doCall(_GriffonPackage_groovy:207)
        at _GriffonPackage_groovy$_run_closure3.doCall(_GriffonPackage_groovy)
        at _GriffonPackage_groovy$_run_closure2.doCall(_GriffonPackage_groovy:186)
        at _GriffonPackage_groovy$_run_closure2.doCall(_GriffonPackage_groovy)
        at RunApplet$_run_closure2.doCall(RunApplet:37)
        at RunApplet$_run_closure2.doCall(RunApplet)
        at gant.Gant$_dispatch_closure4.doCall(Gant.groovy:306)
        ... 5 more

        Andres Almiray added a comment -

        Hi Guillaume.

        Did you create an application named "griffon-wsclient" and ran "griffon run-applet" on it? or did you attempt running "griffon run-applet" on a plugin?

        If the latter then I'm afraid that won't work. Griffon plugins cannot be run as an application as their Grails counterparts can.


          People

          • Assignee:
            Danno Ferrin
            Reporter:
            Jens Hoffmann
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: