GRECLIPSE
  1. GRECLIPSE
  2. GRECLIPSE-909 Groovy Quickfixes in the editor
  3. GRECLIPSE-883

Offer quick fix to implement methods when extending an abstract class or implementing an interface

    Details

    • Type: Sub-task Sub-task
    • Status: Resolved Resolved
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 2.1.0Release, 2.1.1Release
    • Fix Version/s: 2.6.0.Release
    • Component/s: Editor
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Currently if you implement or extend an abstract class you get an error and there is no quick fix to prompt GroovyEclipse to fix the problem by providing stubbed method implementations.

      The same thing with inheriting constructors from super classes. Yes I know GroovyEclipse doesn't do quick fixes yet but I'm raising this so we can track this missing feature.

      What does work however is to do ALT+CMD+S and then select Override/Implement methods, hence again I'm leaving this as minor.

        Activity

        Andrew Eisenberg added a comment -

        Nieraj has been working on quick fix support in Groovy-Eclipse. Perhaps he will have time to look at this.

        Andrew Eisenberg made changes -
        Field Original Value New Value
        Assignee Nieraj Singh [ nisingh ]
        Andrew Eisenberg made changes -
        Parent GRECLIPSE-909 [ 118376 ]
        Issue Type New Feature [ 2 ] Sub-task [ 7 ]
        Andrew Eisenberg made changes -
        Assignee Nieraj Singh [ nisingh ]
        Andrew Eisenberg made changes -
        Component/s Editor [ 13142 ]
        Andrew Eisenberg added a comment -

        Duplicate of GRECLIPSE-927

        Andrew Eisenberg made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Assignee Andrew Eisenberg [ werdna ]
        Fix Version/s 2.6.0.Release [ 17849 ]
        Resolution Duplicate [ 3 ]

          People

          • Assignee:
            Andrew Eisenberg
            Reporter:
            Graeme Rocher
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: