Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8.0.Release
    • Component/s: Compiler Integration
    • Labels:
      None
    • Environment:
      Mac OSX 10.5
      JVM 1.5.0_16
    • Number of attachments :
      3

      Description

      I donīt understand the behaviour of inner enums.

      class Mother {
      	String name
      	Mother.Child child
      	
      	enum Child{
      		Franz,
      		Ferdi,
      		Nand
      	}
      }
      

      Without a package are all things fine.
      But when I use the package familie the groovy compiler have this problem:

      unable to resolve class Mother.Child 
       @ line 5, column 2.
         	Mother.Child child
          ^
      

        Activity

        Andy Clement added a comment -

        I just tried the sample program from above on Eclipse 3.6.1 with the recent greclipse build and it compiled and ran fine (with the package statement). I haven't yet installed the app engine stuff, hard to see how that would be involved as my test project is just a groovy project with that one bit of code in.

        The best thing to do, if you can, is to zip up the minimal failing project and email it to me at aclement AT vmware.com - that would be really helpful. I am 100% sure there is an issue here but if I can't recreate it, it will be very hard to address. Maybe there is something else about the project configuration interfering.

        I am also on Windows7 (64bit) which is a difference, but if I could get hold of the failing project that would be a big help.

        Jeff Schwartz added a comment -

        I emailed you earlier with some new information that I thought might be helpful. I hope it arrived in your inbox.

        To recap, it appears that when I open a workspace containing only my project I don't get the bogus compiler errors but when I open a workspace with multiple projects I do get the errors. As I mentioned in my email, maybe it has something to do with the meta data associated with a workspace and which is used by the plugin system.

        Andy Clement added a comment -

        yep, i got your example code. I am travelling right now and plan to look at it as soon as I can

        Andy Clement added a comment -

        resurrecting this to look into it. Jeff have you still been hitting this? Many things have changed since this was last progressed. I double checked my inbox and found the projects you sent me, I tried them again and they are still behaving for me (I think they always were). I think we left it with me agreeing to do a debug build for you, which unfortunately I didn't get to, but i can do that now if we still think there is something to investigate here.

        Andrew Eisenberg added a comment -

        Well, just tried this one and can't reproduce. Since it's been several years since the last response, assuming that it's no longer a problem. But, please comment or reopen if you still see this.


          People

          • Assignee:
            Andy Clement
            Reporter:
            Jeff Schwartz
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: