GRECLIPSE
  1. GRECLIPSE
  2. GRECLIPSE-708

visualization of deprecated and static references

    Details

    • Type: Improvement Improvement
    • Status: Resolved Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1.0RC2
    • Fix Version/s: 2.1.1Release
    • Component/s: Editor, User Interface
    • Labels:
      None
    • Environment:
      mac osx, last dev release
    • Number of attachments :
      1

      Description

      see screenshot

      the yellow underlined class is a java class which is deprecated.

      behavior is reproducible

        Activity

        Andrew Eisenberg added a comment -

        Interesting...the source locations must be off somehow. I'll have a look at this.

        Peter Niederwieser added a comment -

        I can't tell for sure, but it's likely that the screenshot is from a Spock specification. So this issue might be related to AST transforms.

        Andrew Eisenberg added a comment -

        Having a look at this now. Any chance I can get the code snippet where this is occurring? If not, can you answer some questions:

        1. Do you use any static or * imports?
        2. Is the deprecated class coming from binary or source?

        Andrew Eisenberg added a comment -

        I have a fix in my workspace now. It looks like the Java Semantic highlighter was not properly uninstalled. Now it is and you will not be seeing those spurious strikethroughs. Deprecation will be behaving properly.

        As an added bonus, I added semantic reconciling for static references (italics) and fields (blue).

        This is turning out to be mighty hard to test, so won't be committing right now.

        Andrew Eisenberg added a comment -

        Fixed with regression tests.


          People

          • Assignee:
            Andrew Eisenberg
            Reporter:
            Peter Rietzler
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: