GRECLIPSE
  1. GRECLIPSE
  2. GRECLIPSE-648

Groovy Eclipse has many quirks, feels unstable

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Incomplete
    • Affects Version/s: 2.0.0Release
    • Fix Version/s: 2.1.1Release
    • Component/s: None
    • Labels:
      None
    • Environment:
      GrEclipse 2.0 and later snapshots
      Mac OS 10.6
      Java 6
      Maven-based Enterprise projects (mixed Java/Groovy codebase), Spock project (also mixed Java/Groovy)
    • Number of attachments :
      0

      Description

      Especially for Eclipse power users (which certainly doesn't include me), it's impossible to stay in the flow, because one is constantly interrupted by some latency, error, or otherwise quirky behavior. For example:

      • Short editor freezes
      • Transient compile errors
      • Code completion comes and goes
      • Transient code highlighting problems
      • Wrong indentation on copy & paste
      • Wrong adding of imports

      My impression is that many of these problems result from Groovy Eclipse using outdated information to make its decisions. Often the problems can't be reproduced in a small sample project, and don't go away even if all projects in the workspace are cleaned. Instead, they come and go without apparent reason. But once they hit you, they hit you hard.

      All in all, this turns Groovy Eclipse into a rather unpleasant experience. Groovy Eclipse users in our company are complaining all the time. Too bad they don't take the time to report these issues themselves. I've experienced most of these problems myself, but as a casual user I can't provide as much information.

      Sorry for the harsh feedback. I really appreciate all your hard work!

        Issue Links

          Activity

          Peter Niederwieser added a comment -

          I should add that maybe half of the Groovy code we write is Spock specifications, so some of these things might be related to GrEclipse's AST transform handling. Hard to tell.

          Andrew Eisenberg added a comment -

          Without more information here, it is of course hard to do any fixes for this. However, based on my experience with spock and AST transforms, I am thinking that many of the problems could be related to that. Much of this as well as potential solutions has already been described in GRECLIPSE-617.

          Andrew Eisenberg added a comment -

          Of the issues you describe above, I would believe that code blocks affected by an AST transform could exhibit some of the problems above. Eg, code completion will not work properly under AST transformed code, imports may not be found, and indentation on copy/paste may be wrong as well if the code being pasted into is not being visited due to being transformed by an AST transformation.

          Peter Niederwieser added a comment - - edited

          Yes I understand. But it's the best feedback I could provide for now. Maybe I can do some more pair programming with Groovy Eclipse users at work. Gosh, why don't they just report these issues themselves. But since I want them to use Spock, their Groovy Eclipse issues become mine.

          Andrew Eisenberg added a comment -

          I am closing this issue because either there is not enough information to move any further on this. I believe that some of the problems mentioned here have already been addressed, but I can't be certain without more information such as the precise problem occurring and a reproducible description of the problem.

          Please raise a new issue if you can provide more information.

          Peter Niederwieser added a comment -

          Was about time to close this issue. Groovy Eclipse works much better for us today, and I haven't heard any complaints lately.


            People

            • Assignee:
              Andrew Eisenberg
              Reporter:
              Peter Niederwieser
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: