GRECLIPSE
  1. GRECLIPSE
  2. GRECLIPSE-498

Installation on Eclipse 3.5.1 fails in Ubuntu

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0m1, 2.0.0m2
    • Fix Version/s: 2.0.2Release
    • Component/s: None
    • Labels:
      None
    • Environment:
      Ubuntu 9.10
      JDK 1.6
      Eclipse 3.5.1
    • Number of attachments :
      3

      Description

      Clean install of Ubuntu, and clean install of Eclipse from Ubuntu's package manager.

      Pointing to the Development Build update site for 3.5 ( http://dist.codehaus.org/groovy/distributions/greclipse/snapshot/e3.5/) yields the following error:

      Cannot complete the install because of a conflicting dependency.
      Software being installed: Groovy-Eclipse Feature 2.0.0.xx-20091104-1700-e35 (org.codehaus.groovy.eclipse.feature.feature.group 2.0.0.xx-20091104-1700-e35)
      Software currently installed: Eclipse Platform 3.5.1 (Eclipse Platform 3.5.1)
      Only one of the following can be installed at once:
      Java Development Tools Core 3.5.1.v_972_R35x (org.eclipse.jdt.core 3.5.1.v_972_R35x)
      Java Development Tools Core 3.5.1.xx-20091104-1700-e35 (org.eclipse.jdt.core 3.5.1.xx-20091104-1700-e35)
      Cannot satisfy dependency:
      From: Eclipse Platform 3.5.1 (Eclipse Platform 3.5.1)
      To: org.eclipse.jdt.core [3.5.1.v_972_R35x]
      Cannot satisfy dependency:
      From: Eclipse Platform 3.5.1 (Eclipse Platform 3.5.1)
      To: org.eclipse.jdt.feature.group [3.5.1.r351_v20090810-0600-7r88FEoFHxXYpY3s0jOJPn58EpLN]
      Cannot satisfy dependency:
      From: Groovy-Eclipse Feature 2.0.0.xx-20091104-1700-e35 (org.codehaus.groovy.eclipse.feature.feature.group 2.0.0.xx-20091104-1700-e35)
      To: org.codehaus.groovy.jdt.patch.feature.group [2.0.0.xx-20091104-1700-e35]
      Cannot satisfy dependency:
      From Patch: org.codehaus.groovy.jdt.patch.feature.group 2.0.0.xx-20091104-1700-e35 Eclipse Java Development Tools 3.5.1.r351_v20090810-0600-7r88FEoFHxXYpY3s0jOJPn58EpLN (org.eclipse.jdt.feature.group 3.5.1.r351_v20090810-0600-7r88FEoFHxXYpY3s0jOJPn58EpLN)
      To: org.eclipse.jdt.core [3.5.1.xx-20091104-1700-e35]

      1. feature.xml
        4 kB
        Joel Wiegman
      2. groovy_eclipse_snapshot_error.log
        2 kB
        chocolateboy
      3. groovy_eclipse_stable_error.log
        2 kB
        chocolateboy

        Issue Links

          Activity

          Hide
          chocolateboy added a comment - - edited

          attached error logs

          Show
          chocolateboy added a comment - - edited attached error logs
          Hide
          Andrew Eisenberg added a comment -

          It looks like you have the two update sites installed and activated (the release and the snapshot). Please either disable one of them or uncheck "Contact all update sites...". Let me know if this works for you.

          Show
          Andrew Eisenberg added a comment - It looks like you have the two update sites installed and activated (the release and the snapshot). Please either disable one of them or uncheck "Contact all update sites...". Let me know if this works for you.
          Hide
          chocolateboy added a comment -

          No joy. I removed all sites with "groovy" in the name, then added just the snapshot site:

          http://dist.codehaus.org/groovy/distributions/greclipse/snapshot/e3.5/

          Same "Cannot complete the install because of a conflicting dependency" error, though the details are slightly different:

          http://pastie.org/945866

          Show
          chocolateboy added a comment - No joy. I removed all sites with "groovy" in the name, then added just the snapshot site: http://dist.codehaus.org/groovy/distributions/greclipse/snapshot/e3.5/ Same "Cannot complete the install because of a conflicting dependency" error, though the details are slightly different: http://pastie.org/945866
          Hide
          Andy Clement added a comment -

          Just a note that I downloaded the tar of 3.5.2 (I download by project, JDT version) from the eclipse site and unpacked that, rather than doing anything special to install eclipse. probably makes no difference.

          Show
          Andy Clement added a comment - Just a note that I downloaded the tar of 3.5.2 (I download by project, JDT version) from the eclipse site and unpacked that, rather than doing anything special to install eclipse. probably makes no difference.
          Hide
          chocolateboy added a comment -

          I've gone down the official download route for now (and can confirm again that it's working), but I'd prefer to have this working natively in Ubunbtu. Andrew (Eisenberg), it would be great if you could subscribe to the Launchpad ticket - there's further discussion there.

          Assuming the JDT devs aren't able or willing to provide the hooks Groovy-Eclipse needs, a PPA might be a nice stepping stone to making it a first-class Debian/Ubuntu citizen. If nothing else, getting it working on Ubuntu reduces the chances of newbs like me giving up and using NetBeans

          Thanks, all, for your help.

          Show
          chocolateboy added a comment - I've gone down the official download route for now (and can confirm again that it's working), but I'd prefer to have this working natively in Ubunbtu. Andrew (Eisenberg), it would be great if you could subscribe to the Launchpad ticket - there's further discussion there. Assuming the JDT devs aren't able or willing to provide the hooks Groovy-Eclipse needs, a PPA might be a nice stepping stone to making it a first-class Debian/Ubuntu citizen. If nothing else, getting it working on Ubuntu reduces the chances of newbs like me giving up and using NetBeans Thanks, all, for your help.

            People

            • Assignee:
              Andrew Eisenberg
              Reporter:
              Joel Wiegman
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: