GRECLIPSE
  1. GRECLIPSE
  2. GRECLIPSE-1431

All plugins stop work when GRECLIPSE is installed on Eclipse --- Ubuntu APT distribution

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.6.1.Release
    • Fix Version/s: 2.7.1.Release
    • Component/s: Build and distribution
    • Labels:
      None
    • Environment:
      Ubuntu 12.04 (Precise Pangolin), Eclipse 3.7.2 (Build id: I20110613-1736) by apt-get
    • Number of attachments :
      0

      Description

      Steps to reproduce the issue:
      1 - Get a clean eclipse install by APT (apt-get install eclipse)
      2 - Help->Install New Software
      3 - Using this update site http://dist.springsource.org/release/GRECLIPSE/e3.7/, install "Groovy-Eclipse (Required)". Restart Eclipse.
      4 - In Help -> About Eclipse Platform, the groovy icon does not appear, but can be see in "Installation Details". I don't any plugin stuff like create a groovy project, create groovy class, etc.

      If I try to install other plugins, and then install the groovy-eclipse, all other plugins stop to work, including the groovy-eclipse.

        Activity

        Andrew Eisenberg added a comment -

        Make sure that you have installed Eclipse into a directory that is writable by the current user, otherwise Groovy-Eclipse will not install properly.

        If that doesn't help. then maybe you are hitting this problem: http://groovy.codehaus.org/Eclipse+Plugin+FAQ#EclipsePluginFAQ-QIamrunningLinuxandcannotinstallGroovy-Eclipse

        Anselmo F. Alvarez Jr. added a comment -

        Andrew, there was a bug when try to install groovy-eclipse in ubuntu here: http://jira.codehaus.org/browse/GRECLIPSE-498

        But since ubuntu 11.10 (Oneiric Ocelot) this bug apparently was solve and I can install successfully. But yesterday I have upgraded to the new Ubuntu and I see that my plugins have not started, but I can see that they are installed, the way I described above.

        Andrew Eisenberg added a comment -

        Is your install directory read-only?

        Do you have any relevant errors in your error log?

        Kris De Volder added a comment -

        Note: Anselmo mentioned in his initial report:
        > Eclipse 3.7.2 (Build id: I20110613-1736) by apt-get

        I would recommend to not install Eclipse from the Ubuntu repos. Please try to use an Eclipse downloaded from eclipse.org instead. Also, because Greclipse installs a 'feature patch' as Andrew mentions it needs write access to where the eclipse is installed. My guess would be that the eclipse from Ubuntu repo is installed in the assumption that a single install will be shared by all users and this will probably mean that the installation is write protected and can't be extended with feature patches by individual users.

        I work on Ubuntu (but I'm a bit behind on 10.04 . But I always just download an official eclipse.org eclipse and install it in my Home directory. That typically is the setup that gives me the least amount of headache.

        I'm very distrustful of the repackaged versions in the Ubuntu repos.

        Alaak D'Kar added a comment -

        I used the Ubuntu packaged Eclipse for years now and at least for the last version (11.10) Groovy Eclipse worked perfectly together with it. But since after the upgrade to 12.04 it stopped working and shows the behaviour as explained above. .

        Andrew Eisenberg added a comment -

        Any updates on this? Have you tried using an eclipse from eclipse.org?

        Anselmo F. Alvarez Jr. added a comment -

        I give up.

        I downloaded the last version in eclipse.org and install in writable directory.

        But I really like to use the APT version (why? Because I think it's more organized, more clean).

        I that hope one day may have a solution and I can try again.

        Andrew Eisenberg added a comment -

        Thanks for the feedback. Updating the title to make it more closely reflect the problem.

        There is not too much that we can do. In the past, the problem was how the Ubuntu Eclipse was packaged with its own product feature, that made it not possible to install anything that upgraded the version of one of the core eclipse bundles. I don't know if this is the same problem popping up again, but it does seem to be something similar.

        Your best bet is to raise a bug with the Ubuntu team that manages the Eclipse package.

        Andrew Eisenberg added a comment -

        Here is the previous issue that was raised on Ubuntu's bug tracker:
        https://bugs.launchpad.net/ubuntu/+source/eclipse/+bug/575376

        On a closer reading, it does look like a different problem.

        Anselmo F. Alvarez Jr. added a comment -

        Thanks Andrew for support, i will try open an issue in Ubuntu Bug Track.

        Andrew Eisenberg added a comment -

        And please, add a link to the bug report here.

        Andrew Eisenberg added a comment -

        Did you raise a bug report on the Ubuntu issue tracker?

        Andrew Eisenberg added a comment -

        Any update on this?

        Anselmo F. Alvarez Jr. added a comment -

        Andrew, really sorry for delay, but now I open an Issue on Ubuntu bugtrack: https://bugs.launchpad.net/ubuntu/+source/eclipse/+bug/1024723

        Andrew Eisenberg added a comment -

        I'd recommend moving to Eclipse 4.2. In the latest version of Eclipse, they have done some good work making feature patches installable in read-only directories. This is likely the problem that you are seeing.

        Andrew Eisenberg added a comment -

        I am resolving this issue because there is not much we can do inside Groovy-Eclipse. I am willing to help with the ubuntu team if they have any questions and I will post there.


          People

          • Assignee:
            Andrew Eisenberg
            Reporter:
            Anselmo F. Alvarez Jr.
          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: