GRECLIPSE
  1. GRECLIPSE
  2. GRECLIPSE-1204

Ability to find references to synthetic getter and setter methods using Java/Groovy search

    Details

    • Type: Improvement Improvement
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.5.1Release
    • Fix Version/s: 2.6.0.Release
    • Component/s: Search
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Given this class:

      class First {
        def field
      }
      
      getField()
      setField(new Object())
      

      Find references on field should find getField and setField. We cannot include them through the SearchEngine since that would affect refactoring. There is the org.eclipse.jdt.ui.queryParticipants extension point, which would probably work in this situation.

        Activity

        Andrew Eisenberg added a comment -

        Fixed with regression tests.


          People

          • Assignee:
            Andrew Eisenberg
            Reporter:
            Andrew Eisenberg
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: